View Issue Details

IDProjectCategoryView StatusLast Update
0016640CentOS-7anacondapublic2020-05-07 07:16
Reporteryyxfei 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version7.7-1908 
Target VersionFixed in Version 
Summary0016640: Could not load xfs module when install from PXE
DescriptionWhen I install cenos7.7 from PXE the error message is:
anaconda 21.48.22.156-1 for CentOS7 started.
01:00:24 Running pre-installation
01:00:27 Not asking for VNC because of an automated install
01:00:27 Not asking for VNC because text mode was explicitly asked for kickstart
Traceback (most recent call last):
  File "/sbin/anaconda", line 1259, in <module>
    setupDisplay(anaconda, opts, addon_paths)
  File "/sbin/anaconda", line 735, in setupDisplay
    anaconda.initInterface(addon_paths)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/anaconda.py", line 242, in initInterface
    self.intf = TextUserInterface(self.storage, self.payload
  File "/usr/lib64/python2.7/site-packages/pyanaconda/anaconda.py", line 175, in storage
 
 raise ValueError("new value %s is not valid as a default fs type" % fmt)
ValueError: new value non-existent xfs filesystem is not valid as a default fs type

I check /tmp/storage.log and found xfs module load error, here is the log message from this file:
01:00:25,238 INFO blivet: ISCSID is /sbin/iscsid
01:00:25,238 INFO blivet: no initiator set
01:00:25,254 INFO blivet: no /etc/zfcp.conf; not configuring zfcp
01:00:27,507 DEBUG blivet: Ext4FS.supported: supported: True ;
01:00:27,508 DEBUG blivet: getFormat('ext4') returning Ext4FS instance with object id 0
01:00:27,508 DEBUG blivet: Ext4FS.supported: supported: True ;
01:00:27,508 DEBUG blivet: trying to set new default fstype to 'ext4'
01:00:27,509 DEBUG blivet: Ext4FS.supported: supported: True ;
01:00:27,509 DEBUG blivet: getFormat('ext4') returning Ext4FS instance with object id 1
01:00:27,509 DEBUG blivet: Ext4FS.supported: supported: True ;
01:00:27,524 DEBUG blivet: trying to set new default fstype to 'xfs'
01:00:27,525 DEBUG blivet: XFS.supported: supported: True ;
01:00:27,532 ERR blivet: Could not load kernel module xfs
01:00:27,532 DEBUG blivet: getFormat('xfs') returning XFS instance with object id 2
01:00:27,534 DEBUG blivet: XFS.supported: supported: False ;
01:00:27,533 DEBUG blivet: invalid default fstype: XFS instance (0x7f72fcd24b50) object id 2--
  type = xfs name = xfs status = False
  device = None uuid = None exists = None
  options = defaults
  createOptions = None supported = False formattable = True resizable = False
  mountpoint = None mountopts = None
  label = None size = 0 B targetSize = 0 B

01:00:27,535 DEBUG blivet: XFS.supported: supported: False ;
01:00:27,537 DEBUG blivet: XFS.supported: supported: False ;
Steps To ReproduceReinstall through PXE.
TagsNo tags attached.
abrt_hash
URL

Activities

yyxfei

yyxfei

2019-10-23 02:04

reporter  

install_pxe.jpg (202,720 bytes)
install_pxe.jpg (202,720 bytes)
jinsung.lee

jinsung.lee

2020-01-03 16:22

reporter   ~0035928

hi, yyxfei

  I'm having the same issue as you and I'm writing a solution.

kickstart environment
  After synchronizing the repository with centos 7.6-> centos 7.7, the same thing happened when installing the server with kickstart.

We are using http for package distribution and tftp vmlinuz & initrd.img at pxe.

-- Problem situation --------
http (rpm deploy)
 vmlinuz & initrd.img <- centos 7.7
pxe with tftp
 vmlinuz & initrd.img <- centos 7.6
--------------------------------------

--- Resolution Status ---
http (rpm deploy)
 vmlinuz & initrd.img <- centos 7.7
pxe with tftp
 vmlinuz & initrd.img <-centos 7.7
--------------------------------

If you're in the same environment, I recommend you change to vmlinuz & initrd.img 7.7.
TrevorH

TrevorH

2020-01-03 16:30

manager   ~0035929

It's almost certain that you have the wrong version's initramfs file in your PXE server so you are booting e.g a 7.7 3.10.0-1062.el7 kernel but you mistakenly have the 7.6 initramfs in place that contains the modules for 3.10.0-957.el7 so they do not match (or the other way around, 7.6 kernel, 7.7 initramfs). They must match.
yyxfei

yyxfei

2020-05-07 06:44

reporter   ~0036889

I solved the problem.
When centos release new version it did not change the symlink from old version to new version yet. But I update the new pxe image to installation server.
Then it will install old version os with new pxe image. That 's the reason of the problem.

Cheers
Xiaofei
ManuelWolfshant

ManuelWolfshant

2020-05-07 07:16

manager   ~0036890

You should not do PXE installs directly from public mirrors. What you have met is just one of the many ( and, strangely, more rare ) issues that can occur. )Public mirrors are prone to various other issues derived from the inherent unreliable access via Internet.
You should use instead your own private mirror.

Issue History

Date Modified Username Field Change
2019-10-23 02:04 yyxfei New Issue
2019-10-23 02:04 yyxfei File Added: install_pxe.jpg
2020-01-03 16:22 jinsung.lee Note Added: 0035928
2020-01-03 16:30 TrevorH Note Added: 0035929
2020-05-07 06:44 yyxfei Note Added: 0036889
2020-05-07 07:16 ManuelWolfshant Status new => closed
2020-05-07 07:16 ManuelWolfshant Resolution open => no change required
2020-05-07 07:16 ManuelWolfshant Note Added: 0036890