View Issue Details

IDProjectCategoryView StatusLast Update
0016709CentOS-8sane-backendspublic2019-11-09 01:35
Reportersaxmanrex 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Platformx86_64 (AMD® Fx-8370 eight-core)OSCentosOS Version8.0.1905
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016709: Brother MFC-L3770CDW scanning (via XSane) does not work in Centos 8 after installing via RPM (worked fine in Fedora 30/31).
DescriptionSee Linux Driver page here: https://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=mfcl3770cdw_us_eu_as&os=127

Installing Scanner driver 64 bit (rpm package) 06/03/2019 (0.4.8-1) succeeds.
Connecting to scanner using XSane post-install fails.
Steps To ReproduceNotes:
   - these exact steps worked successfully in both Fedora 30 and 31.
  - The Brother scanner is connected to the network wirelessly at an ip address similar to 192.168.1.2.


1. Goto https://support.brother.com/g/b/downloadlist.aspx?c=us&lang=en&prod=mfcl3770cdw_us_eu_as&os=127
2. Select Scanner driver 64 bit (rpm package) 06/03/2019 (0.4.8-1) 0.12 MB.
3. Agree to EULA and Download.
4. Click on the downloaded file and hit "Install".
5. Enter password and hit "Authenticate".
6. If installation is successful, brsan4 dialog box will say "Remove".
7. Open a terminal, and issue the following commands:
   a. sudo brsaneconfig4 -a name=Brother_MFC_L3770CDW_series model=MFC_L3770CDW_series ip=xxx.xxx.xxx.xxx
   b. brsaneconfig4 -q | grep Brother_MFC_L3770CDW_series
8. After step 7b., a brsaneconfig dialog box will open. In Fedora 30/31, there are 2 options: *MFC_L3770... and MFC_L3770.... In Centos 8, there is only the option *MFC_L3770...
9. In Fedora 30/31, the *MFC...option does not work, you must select the MFC... option. In Centos 8, the MFC...option is not present, and the *MFC option installs but does not work in steps 10 and 11 below.
10. After selecting *MFC in Centos 8, start XSane.
11. XSane will open momentarily and say "scanning for devices". It will then close.

Expected response in steps 10 and 11: ZSane opens and allows you to submits scans via the wireless network.
12. A few seconds later, the following error message weill popup: Failed to open device 'brother 4:net1;dev0': invaslid argument.
Tagsfailure, scanner

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-11-09 00:09 saxmanrex New Issue
2019-11-09 00:09 saxmanrex Tag Attached: failure
2019-11-09 00:09 saxmanrex Tag Attached: scannerr
2019-11-09 00:13 saxmanrex Tag Detached: scannerr
2019-11-09 00:13 saxmanrex Tag Attached: scanner