View Issue Details

IDProjectCategoryView StatusLast Update
0016718CentOS-8xorg-x11-drv-nouveaupublic2019-11-11 15:41
Reporterquartet 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016718: HDMI not working on laptop ASUS Zenbook Pro UX550 with NVIDIA Geforce GTX
DescriptionDescription of problem:

On my new laptop, an ASUS Zenbook Pro UX550 with an NVIDIA Geforce GTX 1050 Ti Mobile card together with an integrated Intel UHD Graphics 630 the HDMI output doesn't work.

I had problem since installation: the graphical installer didn't started. Solved by adding "nouveau.modeset=0" kernel parameters.
After installation rebooted and same problem, resolved with same parameter.
Then I attached an external monitor to the HDMI port, and it doesn't work. I know nouveau.modeset=0 disables nouveau, but without this parameter after the GDM Login the system freezes.

Previous generation of ASUS Zenbook Pro (UX501) with a GTX 960M worked flawlessly.

After searching for a while, found this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=100228

Don't know if it's related, but booting with kernel parameter "nouveau.noaccel=1" the second monitor to work (display in gnome control center shows both monitors), but the system is really slow and sluggish and unusable, and the external monitor doesn't work.

Found also this infos:
https://www.phoronix.com/scan.php?page=news_item&px=Nouveau-Blobs-Pascal-Laptops

Apparently NVIDIA released firmware for Pascal GPU more than 3 months ago, and mine is (NV130 family is Pascal, and mine is NV137 (GP107)), but probably is necessary some work to make nouveau drivers usable.

Is there any temporary workaround? What's the situation with the support or the Pascal architecture in nouveau?

Thanks for the help.


Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-1.0.15-6.fc29.x86_64
linux-firmware-20181008-88.gitc6b6265d.fc29.noarch



Steps To ReproduceHow reproducible:
Boot Fedora with nouveau.modeset=0: without this parameter after the GDM Login the system freezes.

Steps to Reproduce:
1. Boot Fedora with nouveau.modeset=0
2. The internal monitor work well, but connecting an external monitor with the HDMI port doesn't work

Actual results:
External monitor says no signal, and display in gnome control center shows only integrated display

Expected results:
External monitor should work, and display in gnome control center should show both internal ed external monitor
Additional InformationAdditional info:

Output of lspci:
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA controller])
01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] [10de:1c8c] (rev a1)



This is a continuation of a bug reported in the Redhat buzilla forum as this my exact issue and model of laptop and I followed the same procedures to get Centos 8 installed.

https://bugzilla.redhat.com/show_bug.cgi?id=1658561
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-11-11 15:41 quartet New Issue