View Issue Details

IDProjectCategoryView StatusLast Update
0016729CentOS-8iptablespublic2019-11-14 04:08
Reporterifel 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
PlatformOSCentOS 8OS Version1905
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016729: libnftnl-devel is not available in repo, this prevents ppl from building iptables RPM
DescriptionIf you want to rebuild iptables RPM with rpmbuild --rebuild iptables-1.8.2-9.el8.src.rpm it fails with:
error: Failed build dependencies:
        pkgconfig(libnftnl) >= 1.1.1-4 is needed by iptables-1.8.2-9.el8.x86_64

This can be fixed by installing libnftnl-devel-1.1.1-4.el8.x86_64, however it does not exist in the repo.

I fixed this on my box by downloading libnftnl-1.1.1-4.el8.src.rpm, rebuilding it, so I got the bin package, debug pkgs and the devel one:
libnftnl-1.1.1-4.el8.x86_64.rpm
libnftnl-debuginfo-1.1.1-4.el8.x86_64.rpm
libnftnl-debugsource-1.1.1-4.el8.x86_64.rpm
libnftnl-devel-1.1.1-4.el8.x86_64.rpm

It should be published to the repo.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-11-14 04:08 ifel New Issue