View Issue Details

IDProjectCategoryView StatusLast Update
0016788CentOS CI[All Projects] generalpublic2020-02-19 08:37
Reportermafriedm 
PriorityhighSeverityblockReproducibilityrandom
Status closedResolutionfixed 
Summary0016788: Jobs are not being triggered by webhooks or by "Build Now"
DescriptionWe are experiencing intermediate failures to trigger jobs.

Jobs for GitHub Pull Requests are not being triggered every time there is a corresponding event (required comment on PR, new commits to PR).
Here is an example for a PR: https://github.com/openshiftio/saas-openshiftio/pull/1361
This PR should trigger this job: https://ci.centos.org/job/devtools-saas-openshiftio-promote-to-prod-test/

In addition, this PR was merged and the following job was expected to be triggered: https://ci.centos.org/job/devtools-saas-openshiftio-promote-to-prod/
On merge, it wasn't triggered, and we saw the job pending (grey circle) and disappearing.

The same happened when manually triggering the job using the "Build Now" button (logged in).
After hitting "Build Now" a couple more times, the job was triggered.

Notice the missing jobs between builds "1309" and "1313".

Would appreciate assistance on this, as it seems that requests were received (200 on GitHub webhhook result, grey circle, etc), but the builds were not executed.

Thanks a lot!
TagsNo tags attached.

Activities

siddharthvipul1

siddharthvipul1

2020-02-19 08:37

developer   ~0036321

I am not sure what happened, but it could be because of a long queue,
I am only guess for now,
I am closing this as it looks like this hasn't occurred for a while
If it happens again, please open a bug here and assign it to me

Issue History

Date Modified Username Field Change
2019-12-01 10:35 mafriedm New Issue
2019-12-01 10:35 mafriedm Status new => assigned
2020-02-19 08:37 siddharthvipul1 Status assigned => closed
2020-02-19 08:37 siddharthvipul1 Resolution open => fixed
2020-02-19 08:37 siddharthvipul1 Note Added: 0036321