View Issue Details

IDProjectCategoryView StatusLast Update
0016802CentOS-8httpdpublic2019-12-05 21:33
Reporterbenchoff 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016802: mod_md/httpd too old for Let's Encrypt ACME v2.0
Descriptionmod_md fails with
   Permission denied: acme problem urn:acme:error:unauthorized: Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430 for details.

Newer version of Apache httpd/mod_md needed for ACME v2.0 (2.4.40 or later)

Also note: mod_md would not connnect at all until I did "setsebool -P httpd_can_network_connect 1".
Steps To ReproduceConfigure httpd to use mod_md. Restart.
Additional InformationLet's Encrypt end-of-life plan for ACME v1
https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-12-05 21:33 benchoff New Issue