View Issue Details

IDProjectCategoryView StatusLast Update
0016817CentOS-8kernelpublic2020-01-20 17:33
Reportertechnews@highpoint-tech.com 
PriorityurgentSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformNoneOSCentOSOS VersionCentOS8.0
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016817: CentOS8.0 does not support hptiop and mvsas integrated drivers.
DescriptionWhen using HighPoint's RR4520 RAID array card on CentOS 8.0, it prompts that the driver cannot be loaded.
Looking at CONSIDERATIONS IN ADOPTING RHEL 8, I found that in CentOS8.0, the hptiop and mvsas device drivers have been removed from Kernel.
Request to add hptiop and mvsas device drivers back to the list of hardware supported devices in CentOS8.0.
Steps To Reproduce/
Additional Information1.Use instructions in CentOS7.7 and Cent8.0:
#modinfo hptiop
#modinfo mvsas
2.CONSIDERATIONS IN ADOPTING RHEL 8,link:
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/considerations_in_adopting_rhel_8/index
TagsNo tags attached.

Activities

technews@highpoint-tech.com

technews@highpoint-tech.com

2019-12-11 05:16

reporter  

1.png (53,122 bytes)
1.png (53,122 bytes)
toracat

toracat

2019-12-20 01:05

manager   ~0035865

For the devices whose support has been removed from RHEL-8/CentOS-8, you are advised to file a request for the drivers and their DUDs (driver update disks) with ELRepo at http://elrepo.org/bugs . You can see currently available DUDs here:

https://elrepo.org/linux/dud/el8/x86_64/
technews@highpoint-tech.com

technews@highpoint-tech.com

2019-12-20 02:39

reporter   ~0035867

Hello, is there anything different about submitting a report through http://elrepo.org/bugs?
Since CentOS8.0 removed the hptiop and mvsas device drivers, a large amount of user feedback after CentOS7.7 was updated to CentOS8.0, RR4520, RR2720 and other series products cannot be used directly. We can only recommend users to use Cent0S7.7 or other Linux system. This has caused a lot of confusion for some users who need to use CentOS8.0.
Is there a way to add hptiop and mvsas device drivers to CentOS8.0 again? Or add hptiop and mvsas device drivers to the plus kernel? Hope you can provide us a solution so that more users can use CentOS8.0.
Thank you.
toracat

toracat

2019-12-20 08:19

manager   ~0035869

We can only add the drivers to the plus kernel. mvsas is already enabled in the upcoming 8.1 plus kernel. Will enable hptiop as well.

Because the distro kernel cannot be modified like that, you need a DUD image to install the OS. Once done, you can switch to the plus kernel.
toracat

toracat

2019-12-21 01:58

manager   ~0035875

hptiop and mvsas are enabled in kernel-plus-4.18.0-147.3.1.el8_1.centos.plus.
toracat

toracat

2020-01-20 17:33

manager   ~0036078

kernel-plus-4.18.0-147.3.1.el8_1.centos.plus released.

Issue History

Date Modified Username Field Change
2019-12-11 05:16 technews@highpoint-tech.com New Issue
2019-12-11 05:16 technews@highpoint-tech.com File Added: 1.png
2019-12-11 05:16 technews@highpoint-tech.com File Added: Screenshot from 2019-12-10 22-05-45.png
2019-12-11 05:16 technews@highpoint-tech.com File Added: Screenshot from 2019-12-10 22-05-55.png
2019-12-11 05:16 technews@highpoint-tech.com File Added: Screenshot from 2019-12-10 22-13-26.png
2019-12-20 01:05 toracat Note Added: 0035865
2019-12-20 01:05 toracat Status new => acknowledged
2019-12-20 01:05 toracat Description Updated View Revisions
2019-12-20 01:05 toracat Steps to Reproduce Updated View Revisions
2019-12-20 01:05 toracat Additional Information Updated View Revisions
2019-12-20 02:39 technews@highpoint-tech.com Note Added: 0035867
2019-12-20 08:19 toracat Note Added: 0035869
2019-12-21 01:58 toracat Note Added: 0035875
2020-01-20 17:33 toracat Status acknowledged => resolved
2020-01-20 17:33 toracat Resolution open => fixed
2020-01-20 17:33 toracat Note Added: 0036078