View Issue Details

IDProjectCategoryView StatusLast Update
0016837CentOS-7tunedpublic2020-05-01 19:28
ReporterNotAnotherMike 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionnot fixable 
Platformx86_64OSCentOSOS Version7
Product Version7.7-1908 
Target VersionFixed in Version 
Summary0016837: Unable to install kernel-rt and related packages from
DescriptionUnable to install RT kernel and related items. This affects 7.7-1908 and 7.6.1810


Error: Package: tuned-profiles-realtime-2.9.0-1.el7fdp.noarch (rt)
           Requires: tuned = 2.9.0
           Installed: tuned-2.11.0-5.el7_7.1.noarch (@updates)
               tuned = 2.11.0-5.el7_7.1
           Available: tuned-2.7.1-5.el7.noarch (rt)
               tuned = 2.7.1-5.el7
           Available: tuned-2.8.0-5.el7.noarch (rt)
               tuned = 2.8.0-5.el7
           Available: tuned-2.9.0-1.el7fdp.noarch (rt)
               tuned = 2.9.0-1.el7fdp
           Available: tuned-2.11.0-5.el7.noarch (base)
               tuned = 2.11.0-5.el7
Steps To ReproduceAdd repo definition (CentOS-7-rt.repo) to /etc/yum.repos.d
Attempt to install RT kernel.

yum install kernel-rt
Additional Informationyum install kernel-rt-debug
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.hackingand.coffee
 * extras: centos.mirror.constant.com
 * updates: centos.mirror.constant.com
Resolving Dependencies
--> Running transaction check
---> Package kernel-rt-debug.x86_64 0:3.10.0-957.21.3.rt56.935.el7 will be installed
--> Processing Dependency: rt-setup >= 1.55 for package: kernel-rt-debug-3.10.0-957.21.3.rt56.935.el7.x86_64
--> Running transaction check
---> Package rt-setup.x86_64 0:2.0-6.el7 will be installed
--> Processing Dependency: tuned-profiles-realtime for package: rt-setup-2.0-6.el7.x86_64
--> Processing Dependency: tuna for package: rt-setup-2.0-6.el7.x86_64
--> Running transaction check
---> Package tuna.noarch 0:0.13-9.el7 will be installed
---> Package tuned-profiles-realtime.noarch 0:2.9.0-1.el7fdp will be installed
--> Processing Dependency: tuned = 2.9.0 for package: tuned-profiles-realtime-2.9.0-1.el7fdp.noarch
--> Finished Dependency Resolution
Error: Package: tuned-profiles-realtime-2.9.0-1.el7fdp.noarch (rt)
           Requires: tuned = 2.9.0
           Installed: tuned-2.11.0-5.el7_7.1.noarch (@updates)
               tuned = 2.11.0-5.el7_7.1
           Available: tuned-2.7.1-5.el7.noarch (rt)
               tuned = 2.7.1-5.el7
           Available: tuned-2.8.0-5.el7.noarch (rt)
               tuned = 2.8.0-5.el7
           Available: tuned-2.9.0-1.el7fdp.noarch (rt)
               tuned = 2.9.0-1.el7fdp
           Available: tuned-2.11.0-5.el7.noarch (base)
               tuned = 2.11.0-5.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[mcp@centos rpmbuild]$ uname -a
Linux centos.localdomain 3.10.0-1062.9.1.el7.x86_64 #1 SMP Fri Dec 6 15:49:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
TagsNo tags attached.
abrt_hash
URL

Activities

NotAnotherMike

NotAnotherMike

2019-12-17 18:42

reporter  

CentOS-7-rt.repo (160 bytes)
davec

davec

2020-04-27 10:43

reporter   ~0036772

Still broken at 2020-04-27, seen by me with similar install instructions:

e.g.

yum install tune-profiles-nfv
ManuelWolfshant

ManuelWolfshant

2020-04-27 14:38

manager   ~0036774

Unfortunately the content published by CentOS in the -rt folder (and for which no corresponding -rt release rpm was ever provided) is not something suggested for consumption any more. We are evaluating the opportunity of preserving it on the mirrors.
The only safe and recommended approach is an appropriate subscription for RHEL for Real Time from Redhat. Take into account that according to https://access.redhat.com/support/policy/updates/realtime, full support for RHEL for Real Time 7 ended 2 years ago and Maintenance Support will also end in a few months.
JohnnyHughes

JohnnyHughes

2020-05-01 19:23

administrator   ~0036847

Last edited: 2020-05-01 19:24

View 2 revisions

OK .. I have published the latest kenrel-rt. I created this kernel for the Special Interest Group that builds openvswitch. I will try to keep it maintained, but it is not on the same proiority level of base CentOS Linux.

Currently syncing to the mirrors .. should be updated in a couple hours.

JohnnyHughes

JohnnyHughes

2020-05-01 19:28

administrator   ~0036848

Last edited: 2020-05-01 19:28

View 3 revisions

ALSO // your error is because you have the regular tuned installed as well as the one from the RT repo.

If you want to use the RT tuned packages .. you need to add an exclude=tuned* in your CentOS-Base.repo for the os and updates repos.

Issue History

Date Modified Username Field Change
2019-12-17 18:42 NotAnotherMike New Issue
2019-12-17 18:42 NotAnotherMike File Added: CentOS-7-rt.repo
2019-12-17 18:45 NotAnotherMike Tag Attached: 16179
2019-12-17 18:46 NotAnotherMike Tag Detached: 16179
2020-04-27 10:43 davec Note Added: 0036772
2020-04-27 14:38 ManuelWolfshant Status new => closed
2020-04-27 14:38 ManuelWolfshant Resolution open => not fixable
2020-04-27 14:38 ManuelWolfshant Note Added: 0036774
2020-05-01 19:23 JohnnyHughes Note Added: 0036847
2020-05-01 19:24 JohnnyHughes Note Edited: 0036847 View Revisions
2020-05-01 19:28 JohnnyHughes Note Added: 0036848
2020-05-01 19:28 JohnnyHughes Note Edited: 0036848 View Revisions
2020-05-01 19:28 JohnnyHughes Note Edited: 0036848 View Revisions