View Issue Details

IDProjectCategoryView StatusLast Update
0016854CentOS-7gnome-desktop3public2019-12-21 17:25
Status newResolutionopen 
PlatformSR1625URROSCentOSOS Version7.7 (1908)
Product Version7.7-1908 
Target VersionFixed in Version 
Summary0016854: Trying to add Beijing world clock modifies contents of ~/.config directory so that graphics doesn't work at next login
DescriptionIf I click on the time display at the top right corner of the Gnome desktop, choose Add World Clocks, search for Beijing in China, and add it by clicking on the Add button at the top right corner of the dialogue window, the contents of ~/.config is modified in such a way that in the present session everything appears to still be working, but on next login desktop fails to appear, and there is then no way of logging out without rebooting.
Steps To ReproduceIn the attached .tar.gz file is a working version of the ~/.config directory and the broken version that results.

First, when the gdm screen is displayed and *before* logging in, switch to one of the ttys (by ctrl-alt-f2), and run
cd ~
\rm -rf .config
tar -xzf bugshow.20191221a.tar.gz --xattrs-include='*' .config.workingcopy .config.broken
cp -a .config.workingcopy .config

Then switch back to the gdm screen (by ctrl-alt-f1) and login. All should work correctly, though the detailed behaviour and keyboard layout maybe different from what you are used to.

Now click on the time display at the top right hand corner, go to Add World Clocks, hit New, search for Beijing in China, click on it, hit Add (a new clock for Beijing should appear).

At this point the contents of .config will have changed to look more like what is in .config.broken . To confirm that it is now broken, logout and try to login again - the desktop fails to appear. Rebooting fails to fix the problem for this user (but other users still work if they are tried after reboot and *before* the user for whom the problem was executed.

The machine can now be rescued by first rebooting, then *before* logging in, going to one of the ttys and doing

cd ~
\rm -rf .config
cp -a .config.workingcopy .config
restorecon -FR .config

then logging in again.

TagsNo tags attached.




2019-12-21 17:15

reporter   ~0035879

Original compressed file doesn't appear to have uploaded, perhaps because too big. Therefore split into two files and trying again.


2019-12-21 17:17

reporter   ~0035880

Still no evidence that the file has successfully uploaded, trying again.


2019-12-21 17:18

reporter   ~0035881

Third time trying again - if this doesn't work please email me to ask for the attachments.


2019-12-21 17:21

reporter   ~0035882

One last try


2019-12-21 17:25

manager   ~0035883

In any case, CentOS is a rebuild of the sources used to create RHEL. We do not modify anything except to remove branding and logos. Unless you are sure this a CentOS specific bug and not one inherited from RHEL, you will need to submit your request to Redhat via and if/when RH accepts it and incorporates it into RHEL and releases a patched version, then CentOS will pick it up and rebuild it.

Issue History

Date Modified Username Field Change
2019-12-21 17:10 rfs New Issue
2019-12-21 17:15 rfs Note Added: 0035879
2019-12-21 17:17 rfs Note Added: 0035880
2019-12-21 17:18 rfs Note Added: 0035881
2019-12-21 17:21 rfs Note Added: 0035882
2019-12-21 17:25 TrevorH Note Added: 0035883