View Issue Details

IDProjectCategoryView StatusLast Update
0016856CentOS-8rrdtoolpublic2020-01-02 16:22
Reporterindigo423 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016856: RRDTool creates folders/files with arbitrary permissions
DescriptionDescription of problem:

When you use rrdtool-1.7.0-16.el8 in tools that use it in a multithreaded way, e.g. Collectd or OpenNMS, it will create folders/files with arbitrary permissions.
This is a known issue described and solved in RRDTools issue tracker[1]. We ran into this issue in OpenNMS[2] as well. We were able to see this error in rrdtool-1.7.0-16.el8 and after upgrading to 1.7.2 the problem was solved.

I've looked up the AppStream 8 source repository[3] for RRDTool and it seems this patch is not backported to RRDTool 1.7.0. As described in RRDTool it would be required to upgrade RRDTool at least to 1.7.1 or backport the patch to RRDTool 1.7.0.

This issue is reported also in Red Hat Bugzilla[4].

[1] https://github.com/oetiker/rrdtool-1.x/issues/794
[2] https://issues.opennms.org/browse/NMS-12463
[3] https://git.centos.org/rpms/rrdtool/blob/c8/f/SOURCES
[4] https://bugzilla.redhat.com/show_bug.cgi?id=1786084
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-12-23 11:13 indigo423 New Issue