View Issue Details

IDProjectCategoryView StatusLast Update
0016906CentOS-7cloud-utils-growpartpublic2020-01-15 01:48
Reportertstr@atlas.cz 
PrioritynormalSeverityblockReproducibilityalways
Status newResolutionopen 
Platformx86_64OSCentOSOS Version7.7.1908
Product Version7.7-1908 
Target VersionFixed in Version 
Summary0016906: growpart fails in case of use to grow any partition
DescriptionGrowpart failed on case of use to grow any partition. There is an error due to unsupported sfdisk >= 2.26. It blocks all the functionality. All tries to grow partition finished in error "Unexpected output in sfdisk --version [sfdisk fromĀ util-linux 2.23.2]".
It can be reproduced also on Fedora 31 . Only sfdisk version differs, 2.34.
Steps To Reproduceeg. growpart /dev/sda 1
TagsNo tags attached.
abrt_hash
URL

Activities

GregoryYoung

GregoryYoung

2020-01-15 01:48

reporter   ~0036024

My recommendation is to grab the upstream source from the project https://launchpad.net/cloud-utils as in addition to the issue you are seeing, there is a VERY nasty bug with GPT disks larger than 2TB in GrowPart (if you want to see a disk go boom.... the bug is a miscalculation of the last sector, and it put the end of the partition 1 sector past the end of the disk. BOOM!). Their release 0.28 or newer has the fix (Their bug number #1259703). Red Hat upstream has been very slow in updating to a newer version of cloud-utils, and still has not backported the fix for #1259703.

https://bugs.launchpad.net/cloud-utils/+bug/1259703

Issue History

Date Modified Username Field Change
2020-01-09 15:32 tstr@atlas.cz New Issue
2020-01-15 01:48 GregoryYoung Note Added: 0036024