View Issue Details

IDProjectCategoryView StatusLast Update
0016914CentOS-8selinux-policypublic2020-01-13 06:27
Reporterbboozzoo 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016914: selinux policy packages not up to date with RHEL8
DescriptionWhen I try to install snapd, it fails with an error.
Steps To Reproduce# yum install snapd
Última comprobación de caducidad de metadatos hecha hace 2:16:40, el vie 15 nov 2019 09:37:55 CET.
Error:
 Problema: package snapd-2.42.1-1.el8.x86_64 requires snapd-selinux = 2.42.1-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides selinux-policy-base >= 3.14.3-20.el8 needed by snapd-selinux-2.42.1-1.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
TagsNo tags attached.

Relationships

parent of 0016738 resolved Failed to install snapd 

Activities

bboozzoo

bboozzoo

2020-01-11 11:44

reporter   ~0036002

The selinux-policy packages in CentOS8 are not up to date with RHEL8. Packages from EPEL8 that have selinux-policy in their dependencies cannot be installed.

I noticed there is a build of a newer selinux-policy in koji: https://koji.mbox.centos.org/koji/buildinfo?buildID=5028 but it does not appear to have been released to updates.
toracat

toracat

2020-01-13 06:25

manager   ~0036009

selinux-policy-3.14.3-20.el8 is part of CentOS 8.1. It is available if you enable the CR repository ( --enablerepo=cr ).

Issue History

Date Modified Username Field Change
2020-01-11 11:44 bboozzoo New Issue
2020-01-11 11:44 bboozzoo Issue generated from: 0016738
2020-01-11 11:44 bboozzoo Note Added: 0036002
2020-01-11 11:44 bboozzoo Relationship added parent of 0016738
2020-01-13 06:25 toracat Note Added: 0036009
2020-01-13 06:27 toracat Status new => resolved
2020-01-13 06:27 toracat Resolution open => fixed