View Issue Details

IDProjectCategoryView StatusLast Update
0016927CentOS-7net-snmppublic2020-02-06 14:19
Reporterbofo13 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version7.7-1908 
Summary0016927: net-snmp memory leak
DescriptionHi,
snmpd process from net-snmp gets bigger and bigger while it is requested.
Especially when using SNMPv3, SHA and AES.
On some servers process was using more than 500MB of memory, had to restart it to come back to the usual 10MB.
But process then grows again.
Could you look at this please ?
Thank you very much !
Additional Information# uname -r
3.10.0-1062.9.1.el7.x86_64
# cat /etc/centos-release
CentOS Linux release 7.7.1908 (Core)
# yum list installed | grep snmp
net-snmp.x86_64 1:5.7.2-43.el7 @base
net-snmp-agent-libs.x86_64 1:5.7.2-43.el7 @base
net-snmp-libs.x86_64 1:5.7.2-43.el7 @base
net-snmp-perl.x86_64 1:5.7.2-43.el7 @base
net-snmp-utils.x86_64 1:5.7.2-43.el7 @base
TagsNo tags attached.
abrt_hash
URL

Activities

tigalch

tigalch

2020-01-18 20:47

manager   ~0036049

You have to report this bug to RedHat. Once/If they fix it, CentOS will automatically inherit the fix (as we only rebuild what RH releases).
bofo13

bofo13

2020-01-22 20:01

reporter   ~0036098

Thank you, please see https://bugzilla.redhat.com/show_bug.cgi?id=1794168.
bofo13

bofo13

2020-01-28 11:13

reporter   ~0036146

Bug fixed upstream.
tigalch

tigalch

2020-02-04 19:19

manager   ~0036201

RH released net-snmp-5.7.2-43.el7_7.3 today, rebuild will follow shortly. Let's see then if this is fixed (contrary to what is said in RHs bugzilla entry).
bofo13

bofo13

2020-02-04 20:33

reporter   ~0036203

Good news, many thanks @tigalch.

-> contrary to what is said in RHs bugzilla entry
Nothing is said there yet ? (https://bugzilla.redhat.com/show_bug.cgi?id=1794168)
tigalch

tigalch

2020-02-05 06:22

manager   ~0036204

Well, yes. The bug report at RH says "will be fixed in 7.8". Since this package is not for/from 7.8 it might not contain the fix. Thus my query if the new package would fix it or if we have to wait for 7.8 GA.
bofo13

bofo13

2020-02-06 11:52

reporter   ~0036216

Issue solved in 5.7.2-43.el7_7.3, bug does not reproduce, perfect, thank you again !
tigalch

tigalch

2020-02-06 14:19

manager   ~0036217

Closing per reporters feedback

Issue History

Date Modified Username Field Change
2020-01-15 11:46 bofo13 New Issue
2020-01-18 20:47 tigalch Note Added: 0036049
2020-01-22 20:01 bofo13 Note Added: 0036098
2020-01-28 11:13 bofo13 Note Added: 0036146
2020-02-04 19:19 tigalch Note Added: 0036201
2020-02-04 20:33 bofo13 Note Added: 0036203
2020-02-05 06:22 tigalch Note Added: 0036204
2020-02-06 11:52 bofo13 Note Added: 0036216
2020-02-06 14:19 tigalch Status new => resolved
2020-02-06 14:19 tigalch Resolution open => fixed
2020-02-06 14:19 tigalch Fixed in Version => 7.7-1908
2020-02-06 14:19 tigalch Note Added: 0036217