View Issue Details

IDProjectCategoryView StatusLast Update
0016930CentOS-8rustpublic2020-01-16 16:04
Reporterrgmorris 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status acknowledgedResolutionopen 
Product Version8.1.1911 
Target VersionFixed in Version 
Summary0016930: rust-1.37.0-1.module_el8.1.0+246+1f1fd47e built against old libLLVM-7.so
DescriptionHi,

Trying to update from 8.0.1905 to 8.1.1911:

   Problem 2: package rust-1.37.0-1.module_el8.1.0+246+1f1fd47e.x86_64 requires libLLVM-7.so()(64bit), but none of the providers can be installed

Whereas 8.0 contained llvm-libs-7, 8.1 contains llvm-libs-8. So it looks like the rust rpm was built against an older version of llvm.
Steps To ReproduceIn 8.1.1911:

 rpm -qRp AppStream/x86_64/kickstart/Packages/rust-1.37.0-1.module_el8.1.0+246+1f1fd47e.x86_64.rpm | grep libLLVM
   -> libLLVM-7.so()(64bit)

 rpm -qlp AppStream/x86_64/kickstart/Packages/llvm-libs-8.0.1-1.module_el8.1.0+215+a01033fb.x86_64.rpm | grep libLLVM
   -> /usr/lib64/libLLVM-8.0.1.so

Additional InformationCan't see a "rust" category to assign this report to.
TagsNo tags attached.

Activities

toracat

toracat

2020-01-16 07:26

manager   ~0036031

Category 'rust' created.

Issue History

Date Modified Username Field Change
2020-01-15 23:30 rgmorris New Issue
2020-01-16 07:26 toracat Status new => acknowledged
2020-01-16 07:26 toracat Category -OTHER => rust
2020-01-16 07:26 toracat Note Added: 0036031