View Issue Details

IDProjectCategoryView StatusLast Update
0016959CentOS-8openldappublic2021-04-23 09:39
Reporterrgmorris Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status feedbackResolutionopen 
Product Version8.1.1911 
Summary0016959: Missing openldap-servers rpm in 8.1
DescriptionHi,

CentOS 8.0 includes an openldap-servers rpm as:
8.0.1905/PowerTools/x86_64/os/Packages/openldap-servers-2.4.46-9.el8.x86_64.rpm

In CentOS 8.1, there seems to be no openldap-servers package.
I rebuilt the 8.1 source rpm openldap-2.4.46-10.el8.src.rpm locally, and an openldap-servers-2.4.46-10.el8.x86_64.rpm
was generated. So I don't see why it is apparently missing from CentOS 8.1.

Thanks.
Steps To ReproduceInstall a CentOS 8.0 system
dnf install openldap-servers
Try to update to CentOS 8.1.
Additional InformationMaybe mirrors a problem in RHEL?
https://bugzilla.redhat.com/show_bug.cgi?id=1787478

Since it just involves rebuilding a src rpm, I don't see why it could not be fixed independently from RHEL.
TagsNo tags attached.

Activities

bstinson

bstinson

2020-01-22 19:50

administrator   ~0036097

This does indeed match RHEL. If something changes upstream, we will match that.

https://access.redhat.com/solutions/2440481
adamboutcher

adamboutcher

2020-08-18 08:44

reporter   ~0037571

Still an issue in CentOS 8.2, it's a dependency for many other packages which means moving to CentOS 8.x is not yet possible.
oernii

oernii

2020-09-21 09:35

reporter   ~0037714

Symas has build an RPM and created an OpenLDAP server repo: https://repo.symas.com/sofl/rhel8/
dand

dand

2021-04-22 23:34

reporter   ~0038410

Just pointing out that AlmaLinux has openldap-servers in their 8.3 PowerTools repo. Seems strange considering that they're also claiming 1:1 compatibility with RHEL.

https://repo.almalinux.org/almalinux/8.3/PowerTools/x86_64/os/Packages/openldap-servers-2.4.46-15.el8.x86_64.rpm
toracat

toracat

2021-04-23 09:39

manager   ~0038416

It looks as if AlmaLinux is not matching RHEL. As noted in the solution article referenced by @bstinson, openldap-servers has been deprecated in RHEL. The last package in RHEL8 was 2.4.46-9.el8.

Note that this is one of those packages that are built but are not released upstream. CentOS matches RHEL in that sense. You can see that it was indeed built:

 https://koji.mbox.centos.org/koji/buildinfo?buildID=13675 .

Issue History

Date Modified Username Field Change
2020-01-22 01:23 rgmorris New Issue
2020-01-22 19:50 bstinson Status new => feedback
2020-01-22 19:50 bstinson Note Added: 0036097
2020-08-18 08:44 adamboutcher Note Added: 0037571
2020-09-21 09:35 oernii Note Added: 0037714
2021-04-22 23:34 dand Note Added: 0038410
2021-04-23 09:39 toracat Note Added: 0038416