View Issue Details

IDProjectCategoryView StatusLast Update
0016964CentOS-7selinux-policypublic2020-01-22 13:46
ReporterLinisdjxm 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformOSOS Version7
Product Version 
Target VersionFixed in Version 
Summary0016964: SELinux is preventing rtkit-daemon from 'sys_ptrace' accesses on the cap_userns labeled rtkit_daemon_t.
DescriptionDescription of problem:
I tried to use an audio that played in a web page, and then this error occurred.

I feel sorry because I have to use a simple translation program to translate Chinese into English.
SELinux is preventing rtkit-daemon from 'sys_ptrace' accesses on the cap_userns labeled rtkit_daemon_t.

***** Plugin catchall (100. confidence) suggests **************************

如果你相信 rtkit-daemon应该允许_BASE_PATH sys_ptrace 访问 cap_userns标记 $TARGET默认为_TYPE。
Then 应该将这个情况作为 bug 报告。
可以生成本地策略模块以允许此访问。
Do
暂时允许此访问权限执行:
# ausearch -c 'rtkit-daemon' --raw | audit2allow -M my-rtkitdaemon
# semodule -i my-rtkitdaemon.pp

Additional Information:
Source Context system_u:system_r:rtkit_daemon_t:s0
Target Context system_u:system_r:rtkit_daemon_t:s0
Target Objects Unknown [ cap_userns ]
Source rtkit-daemon
Source Path rtkit-daemon
Port <Unknown>
Host (removed)
Source RPM Packages
Target RPM Packages
Policy RPM selinux-policy-3.13.1-252.el7_7.6.noarch
Selinux Enabled True
Policy Type targeted
Enforcing Mode Enforcing
Host Name (removed)
Platform Linux (removed) 5.4.13-1.el7.elrepo.x86_64 #1 SMP
                              Fri Jan 17 15:34:12 EST 2020 x86_64 x86_64
Alert Count 1
First Seen 2020-01-22 20:48:31 CST
Last Seen 2020-01-22 20:48:31 CST
Local ID f7e5c68e-9d66-411e-bbaf-b5df50fe3ed7

Raw Audit Messages
type=AVC msg=audit(1579697311.191:228): avc: denied { sys_ptrace } for pid=878 comm="rtkit-daemon" capability=19 scontext=system_u:system_r:rtkit_daemon_t:s0 tcontext=system_u:system_r:rtkit_daemon_t:s0 tclass=cap_userns permissive=0


Hash: rtkit-daemon,rtkit_daemon_t,rtkit_daemon_t,cap_userns,sys_ptrace

Version-Release number of selected component:
selinux-policy-3.13.1-252.el7_7.6.noarch
Additional Informationreporter: libreport-2.1.11.1
hashmarkername: setroubleshoot
kernel: 5.4.13-1.el7.elrepo.x86_64
reproducible: Not sure how to reproduce the problem
type: libreport
TagsNo tags attached.
abrt_hash5cb01176e79af3869e500df9de4f681f863d10f3b460ff1a84dafba720dcc387
URL

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-01-22 13:46 Linisdjxm New Issue