View Issue Details

IDProjectCategoryView StatusLast Update
0016971CentOS-8kernel-pluspublic2020-02-15 21:39
Reporterpseud 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version8.1.1911 
Target VersionFixed in Version 
Summary0016971: sata_uli devicel driver request
DescriptionI guess 2005 is a long time ago now...
First I discovered the wifi's so old that it's been dropped from the kernel at el8:
https://forums.centos.org/viewtopic.php?f=54&t=72163#p303513
Ghanks to toracat & pperry, the wifi's back up:
https://bugs.centos.org/view.php?id=16635
https://elrepo.org/bugs/view.php?id=959

Now, I've stuck a sata cardbus card in the machine get some raid mileage out of some old hard drives, and... Just like the wifi, it's gone in el8:
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/considerations_in_adopting_rhel_8/index#removed-device-drivers_hardware-enablement
Which says:
11.1.1. Removed device drivers
Support for the following device drivers has been removed in RHEL 8:
...
* ata drivers::
...
 sata_uli

Would it be possible to include the sata_uli driver for 8.2 (8.1 having been just missed)?
Steps To Reproducen/a
Tagssata_uli

Activities

pseud

pseud

2020-01-25 20:47

reporter   ~0036123

btw, it looks like nvidia bought out ALI/ ULI some time back and keep some antique source here:
https://download.nvidia.com/ULi/ULi_SATA%20RAID_Linux_%20v0.9p.zip
toracat

toracat

2020-01-26 00:32

manager   ~0036124

This is now being handled in ELRepo's bug tracker https://elrepo.org/bugs/view.php?id=984 .
toracat

toracat

2020-01-26 08:13

manager   ~0036125

SATA_ULI will be enabled in the next kernel-plus update.
toracat

toracat

2020-01-30 00:47

manager   ~0036155

kmod-sata_uli-1.3-1.el8_1.elrepo.x86_64.rpm is now available in the elrepo-testing repository. Its DUD image is also available.
pseud

pseud

2020-01-31 10:47

reporter   ~0036168

Thank you - I'll follow up at https://elrepo.org/bugs/view.php?id=984
toracat

toracat

2020-02-15 21:39

manager   ~0036294

kernel-plus--4.18.0-147.5.1.el8_1.centos.plus has SATA_ULI enabled.

Issue History

Date Modified Username Field Change
2020-01-25 20:37 pseud New Issue
2020-01-25 20:37 pseud Tag Attached: sata_uli
2020-01-25 20:47 pseud Note Added: 0036123
2020-01-26 00:32 toracat Note Added: 0036124
2020-01-26 00:32 toracat Status new => assigned
2020-01-26 08:13 toracat Note Added: 0036125
2020-01-30 00:47 toracat Note Added: 0036155
2020-01-31 10:47 pseud Note Added: 0036168
2020-02-15 21:39 toracat Note Added: 0036294
2020-02-15 21:39 toracat Status assigned => resolved
2020-02-15 21:39 toracat Resolution open => fixed