View Issue Details

IDProjectCategoryView StatusLast Update
0016985CentOS-8anacondapublic2020-01-29 18:00
Reportermattpie 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Platformx86_64OSCentOSOS Version8
Product Version8.1.1911 
Target VersionFixed in Version 
Summary0016985: Anaconda disk tool cannot create EFI partition on Mac Mini
DescriptionOn an old Mac Mini (mid-2010), the Anaconda disk utility crashes when automatically partitioning, and throws an error regarding HFS+ EFI and Linux when manually partitioning. This blocks the installer from proceeding. The CentOS 7 installer creates a vfat EFI parition and installs without issue on the same hardware. I don't have any other Mac hardware to test, unfortunately to see if it's particular to this hardware type.
Steps To ReproduceBoot CentOS 8 installer on Mac, attempt to partition disks automatically or manually.
Additional InformationSteps that didn't help:
- Wiped forst 2GB of disk with dd to make sure it wasn't something in the table that Anaconda couldn't handle
- Tried standard Centos 8 and stream installer
- Reinstalled MacOS 10.14 (High Sierra), and then tried to re-use the created EFI partition in the Centos 8 installer but got the same error
- Tried to manually create the partition structure in fdisk

Will attach diagnostic file shortly.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-01-29 18:00 mattpie New Issue