View Issue Details

IDProjectCategoryView StatusLast Update
0017017CentOS-7rpmpublic2020-02-06 20:05
Reporterasim.butt 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0017017: glog rpm installation fails if openstack-train repo is enabled
Descriptionyum install glog fails in CentOS if openstack-train repo is enabled.

$ sudo yum install glog
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
openstack-train: mirror2.evolution-host.com
rdo-qemu-ev: mirror.dst.ca
Resolving Dependencies
--> Running transaction check
---> Package glog.x86_64 0:0.3.3-8.el7 will be installed
--> Processing Dependency: gflags for package: glog-0.3.3-8.el7.x86_64
--> Processing Dependency: libgflags.so.2.1()(64bit) for package: glog-0.3.3-8.el7.x86_64
--> Running transaction check
---> Package gflags.x86_64 0:2.2.1-1.el7 will be installed
---> Package glog.x86_64 0:0.3.3-8.el7 will be installed
--> Processing Dependency: libgflags.so.2.1()(64bit) for package: glog-0.3.3-8.el7.x86_64
--> Finished Dependency Resolution
Error: Package: glog-0.3.3-8.el7.x86_64 (epel)
Requires: libgflags.so.2.1()(64bit)
Available: gflags-2.1.1-6.el7.x86_64 (epel)
libgflags.so.2.1()(64bit)
Installing: gflags-2.2.1-1.el7.x86_64 (openstack-train)
~libgflags.so.2.2()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Steps To Reproduce1. Ensure epel and openstack-train repos are enabled
2. yum install glog
Tagsyum
abrt_hash
URL

Activities

tigalch

tigalch

2020-02-06 20:05

manager   ~0036221

I'm pretty sure both of these repositories are not from CentOS but from 3rd parties. You should contact the repo providers about those issues, as they are not CentOS operated.

Issue History

Date Modified Username Field Change
2020-02-06 18:52 asim.butt New Issue
2020-02-06 18:52 asim.butt Tag Attached: yum
2020-02-06 20:05 tigalch Note Added: 0036221