View Issue Details

IDProjectCategoryView StatusLast Update
0017059CentOS-8kmod-kvdopublic2020-03-21 23:37
Reportermmarusak 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0017059: modprobe kvdo fails: kernel version mismatch
DescriptionWith the latest update of centos-8-stream image in Cockpit team we noticed that kvdo is broken:

# modinfo vdo
modinfo: ERROR: Module vdo not found.

# find /lib/modules -name '*vdo*'
/lib/modules/4.18.0-151.el8.x86_64/weak-updates/kmod-kvdo
/lib/modules/4.18.0-151.el8.x86_64/weak-updates/kmod-kvdo/vdo
/lib/modules/4.18.0-151.el8.x86_64/weak-updates/kmod-kvdo/vdo/kvdo.ko
/lib/modules/4.18.0-147.6.el8.x86_64/extra/kmod-kvdo
/lib/modules/4.18.0-147.6.el8.x86_64/extra/kmod-kvdo/vdo
/lib/modules/4.18.0-147.6.el8.x86_64/extra/kmod-kvdo/vdo/kvdo.ko


# uname -r
4.18.0-168.el8.x86_64

The version of kernel does not match the version of module.
Steps To Reproduce# modprobe kvdo
modprobe: FATAL: Module kvdo not found in directory /lib/modules/4.18.0-168.el8.x86_64
Additional Information$ rpm -q kernel
kernel-4.18.0-151.el8.x86_64
kernel-4.18.0-168.el8.x86_64

$ rpm -q kmod-kvdo
kmod-kvdo-6.2.1.138-57.el8.x86_64
TagsNo tags attached.

Activities

mmarusak

mmarusak

2020-03-20 16:58

reporter   ~0036544

Seems to be working with the current build.
(I have no idea how to close this issue though).

Issue History

Date Modified Username Field Change
2020-02-17 12:26 mmarusak New Issue
2020-03-20 16:58 mmarusak Note Added: 0036544
2020-03-21 23:37 toracat Status new => resolved
2020-03-21 23:37 toracat Resolution open => fixed