View Issue Details

IDProjectCategoryView StatusLast Update
0017061CentOS-8kernelpublic2020-02-17 13:05
Reportersz_wolfi 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformHP Elitebook 840 G6OSCentosOS Version8.1
Product Version8.1.1911 
Target VersionFixed in Version 
Summary0017061: builtin e1000e Ethernet driver is unusable/slow on HP Elitebook 840 G6
DescriptionI've just tried to PXE-boot this laptop (HP-Elitebook 840 G6) - and observed, that it takes waaay too long.
...installed via WIFI - which worked - but ended up again in a totally unusable/slow ethernet (attached to a Cisco-switch).

From 'ethtool' or 'dmesg' (or the switch's logs) - nothing looks wrong - it negotiates to 1000-full-duplex - but is slow.
(forcing it to lower speeds or different duplex/flow-control settings - doesn't change the behavior at all)

lspci says:
>00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (6) I219-LM (rev 11)

The symptom is always (if you're on ethernet) - that ethernet works - but is unusably SLOW.

PINGs - in both directions are in the 4-digit range (multiple seconds) - and ttcp/iperf gets only a few Kbytes(!) per sec.

I've tried so far:
kernel-core-4.18.0-147.3.1.el8_1.x86_64
kernel-core-4.18.0-147.5.1.el8_1.x86_64
kernel-core-4.18.0-147.el8.x86_64

none of those changes the behavior.

The actual FIX - is just to download/compile/install - intel's out-of-tree driver:

-rw-r--r-- 1 root root 314091 Feb 17 12:52 e1000e-3.6.0.tar.gz

it compiles out of the box - and if you overwrite the old driver --- things WORK with the expected speed.
Steps To Reproducejust try to PXE-boot or NET-install Centos-8.1 - on a HP Elitebook 840 G6 via wired Ethernet.
Try 'ttcp' or 'iperf' via ethernet - it'll be just dog slow.
ping - reports multiple-seconds (1000+ ms) round-trip-times.
WLAN isn't affected by this at all.
Additional InformationIt would be nice - to have this newer driver included in future kernel-updates ...
Tags"Network"

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-02-17 12:58 sz_wolfi New Issue
2020-02-17 12:58 sz_wolfi Tag Attached: "Network"