View Issue Details

IDProjectCategoryView StatusLast Update
0017064CentOS CI[All Projects] generalpublic2020-03-06 19:20
Reportermkoncek 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0017064: Java Packaging HOWTO - duffy key not recognized
DescriptionThe duffy key assigned to this project is not recognized during build.

https://jenkins-fedora-java-sig.apps.ci.centos.org/job/Java%20Packaging%20HOWTO/
TagsNo tags attached.

Activities

siddharthvipul1

siddharthvipul1

2020-02-19 07:54

developer   ~0036319

After checking your .cicopipeline, there are 2 things I would like you to do
1. Remove line 23
2. On line 8, replace `node()` with `node('cico-workspace')`
Please confirm if things work once you have done that
mkoncek

mkoncek

2020-02-20 07:29

reporter   ~0036356

First time i tried it it outputed: "‘cico-workspace-4k0ck’ is offline"
When i tried to use `node()` it outputed: "cico: command not found"
Second time i tried with "cico-workspace" it outputed: "‘Jenkins’ doesn’t have label ‘cico-workspace’"
bstinson

bstinson

2020-03-06 19:20

administrator   ~0036476

Ok part of the trouble was some missing information in the openshift secrets (the SSH key portion) that is fixed, as is the trouble using the node('cico-workspace') selector.

Please don't modify the master node configuration, adding labels there causes the master node to pick up work before openshift can spin up a workspace container for you. The workspace container is the one that contains all of the necessary tools to request/release duffy nodes.

Here's a job that was able to request a node and perform some operations:
https://jenkins-fedora-java-sig.apps.ci.centos.org/job/Java Packaging HOWTO/20

Marking this done.

Issue History

Date Modified Username Field Change
2020-02-18 13:35 mkoncek New Issue
2020-02-18 13:35 mkoncek Status new => assigned
2020-02-19 07:54 siddharthvipul1 Status assigned => feedback
2020-02-19 07:54 siddharthvipul1 Note Added: 0036319
2020-02-20 07:29 mkoncek Note Added: 0036356
2020-02-20 07:29 mkoncek Status feedback => assigned
2020-03-06 19:20 bstinson Status assigned => resolved
2020-03-06 19:20 bstinson Resolution open => fixed
2020-03-06 19:20 bstinson Note Added: 0036476