View Issue Details

IDProjectCategoryView StatusLast Update
0001719CentOS-5xorg-x11-drv-atipublic2014-03-05 20:31
ReporterPatrickMoelands 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
Product Version5.0 
Target VersionFixed in Version 
Summary0001719: xorg.conf is not configured properly during installation
DescriptionAfter installation, X / Gnome does not function properly. Graphics are very garbled. Removing xorg.conf and thus triggering x-config does not work, in fact, booting into runlevel 3 is the only way to get the system working.

Hardware: Compaq ProLiant ML350 (2x P3 733mhz), integrated ATI Mach64 3D Rage II, 512 mb RAM ECC, Compaq Smart Array 431 controller, 3x 18gb SCSI configured as RAID0, Intel Corporation 82557/8/9 [Ethernet Pro 100]
Additional InformationProblem can be solved by using the xorg.conf file from a similar server (running CentOS 4.4).

Uploaded xorg.conf file is the original generated configuration file.
TagsNo tags attached.

Relationships

related to 0001882 assignedkbsingh@karan.org radeon driver fails for ATI 8500DV 

Activities

2007-03-03 11:35

 

xorg.conf (616 bytes)
PatrickMoelands

PatrickMoelands

2007-03-04 09:47

reporter   ~0004527

After doing a new and clean install (this time with rhgb),
the graphics stay garbled, also when firstboot comes into action.

Solution: reboot into runlevel 3.
Copy the formentioned xorg.conf file from the similar server onto the computer and reboot. Rhgb works perfectly, unfortunately, firstboot doesn't kick into action after reboot.
PatrickMoelands

PatrickMoelands

2007-03-04 19:03

reporter   ~0004528

On request of Johnny Hughes, I also checked this problem with a clean install of RHEL5 beta 2. Here too the above mentioned problems occur.

Installation (without vga=773 added) went fine, also firstboot went without any problem. Rebooting (because I switched SELinux off) caused the graphics during the splash-screen to become garbled and stay like that. CTRL+F1 - F8 doesn't respond. Cold reboot + xorg.conf file from twin-server did the trick.

Adding vga=773 has as result that without rhgb, I don't see any lines (including the [OK]).

Attached file is the RHEL5 generated xorg.conf

2007-03-04 19:03

 

rhel5-org.conf (597 bytes)

2007-03-04 19:04

 

patrickmoelands-xorg-working.conf (2,828 bytes)
JohnnyHughes

JohnnyHughes

2007-04-02 09:42

administrator   ~0004751

This must be specific to your hardware / graphics combination.

Does it still happen with the latest QA tree?
PatrickMoelands

PatrickMoelands

2007-04-03 07:48

reporter   ~0004760

Yes, the latest tree also causes the problem.
range

range

2007-04-20 05:00

administrator   ~0004868

Does this also happen in final?
PatrickMoelands

PatrickMoelands

2007-04-20 14:26

reporter   ~0004899

Last edited: 2007-04-20 15:07

Yes, even in CentOS 5.0 (final) the problem is still there.

[edited/extra info]
Additional, I have the problem also on my own pc (P4 motherboard with a GeForce2 Pro videocard). Here too, the xorg.conf file is extremely basic (no module section, no monitor info, no videocard info).

range

range

2007-04-20 15:51

administrator   ~0004901

Hmmm never saw that dring m installs.

Moving from 5.0 beta to 5.0
PatrickMoelands

PatrickMoelands

2007-04-30 02:55

reporter   ~0005011

I've worked out the problem.

Two problems which seem related. During installation, the monitor isn't detected/configured properly (specific entries are missing from the new xorg.conf file). As a result of this, no usable info is present and the graphical login gets garbled.

Furthermore, there are more specifications missing (the complete "Module" section is gone). This won't help after configurating a graphical card.

Workaround is simple, read here: http://www.linuxforums.org/forum/redhat-fedora-linux-help/92715-centos-5-0-installation-woes-tips-tricks.html

This problem has been tested on several independant systems (P3 + ATI, P3 + I810 and P4 + NVIDIA) and symptoms + cure is always the same.
range

range

2007-04-30 03:33

administrator   ~0005012

Last edited: 2007-04-30 03:35

But that only happens *IF* your monitor isn't detected properly. If it is, you get a usable Xorg.conf afterwards.

Keep in mind that Xorg7.1 works with a much smaller set of information in Xorg.conf, as most things are autodetected nowadays.

The Modules section normally isn't needed anymore, for example.

PatrickMoelands

PatrickMoelands

2007-05-01 04:40

reporter   ~0005047

The Modules section is needed to get the Nvidia (legacy) driver working. Without it, no GLX extensions (to name something).
range

range

2007-05-01 10:38

administrator   ~0005052

Yes, but the ncidia driver install script will configure that part of your xorg.conf.
PatrickMoelands

PatrickMoelands

2007-05-01 11:37

reporter   ~0005054

Sure ... that is why I need to manually add those lines AFTER I install the Nvidia driver. Perhaps the newest non-legacy does, but the legacy driver doesn't.
range

range

2007-05-01 14:27

administrator   ~0005057

Yes, but should we care about closed drivers? Because with the recognized nv driver, the GLX module won't do anything for you. And other cards do work without that.

[ralph@logout ~]$ xdpyinfo | grep "number of extensions"
number of extensions: 31
[ralph@logout ~]$ grep -i modul /etc/X11/xorg.conf
[ralph@logout ~]$ glxinfo | grep rendering
direct rendering: Yes
PatrickMoelands

PatrickMoelands

2007-05-01 14:47

reporter   ~0005058

Getting any kind of monitor properly configured should be the main focus point.
Using CentOS 4.x without problems, switching to CentOS 5.0 and having these kind of problems will make people leave.

I tested CentOS 5.0 tonight on a P2 laptop, did a clean install and restarted it. NO graphicsl screen, just ending up with runlevel 3. Startx gave me errors! And that when CentOS 4.4 never gave any problem. Doing a system-config-display solved it.
reloftin

reloftin

2007-05-06 20:04

reporter   ~0005099

I have been trying to update my CentOS 4 kickstart files to CentOS 5 and found that no matter what I use as options to the "monitor" keyword, there is no "Monitor" section created in /etc/X11/xorg.conf for a monitor that does not respond to autodetection. Since this behavior seems to be independent of the video card chipset ( I get it on NVidia TNT Model 64 ) I'm also wondering if the category this bug is assigned to is appropriate.
range

range

2007-05-07 04:13

administrator   ~0005100

Can anyone test that on RHEL5? And then open a bug upstream if that also happens there, as we're not going to change the X sources ...
range

range

2007-05-07 04:17

administrator   ~0005101

Maybe related to https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=234401
reloftin

reloftin

2007-05-11 16:14

reporter   ~0005155

I have opened this bug with RedHat as

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239827
PatrickMoelands

PatrickMoelands

2007-07-27 08:16

reporter   ~0005732

Just for the record, this problem still exsists.
timverhoeven

timverhoeven

2007-11-22 15:53

developer   ~0006362

Patrick, have you already been able to test this with the 5.1 tree ?
PatrickMoelands

PatrickMoelands

2007-11-23 11:33

reporter   ~0006366

Yes I have.

This problem also occurs when installing CentOS 5.1 (and RHEL5.1 and Fedora 8).

Solution is the same.
toracat

toracat

2007-11-23 17:12

manager   ~0006370

The URL in note 5011 does not exist. Has this been deleted?
PatrickMoelands

PatrickMoelands

2007-11-23 17:55

reporter   ~0006373

URL has indeed changed.

New one: http://www.linuxforums.org/forum/redhat-fedora-linux-help/95675-centos-5-0-rhel5-fedora-7-installation-problems-tips-tricks.html
arrfab

arrfab

2007-11-23 20:46

administrator   ~0006376

can you explain in details the problems you have ? And don't mix it with the vga= kernel parameter bug that is an other and well known (and now fixed) issue : http://bugs.centos.org/view.php?id=1809
PatrickMoelands

PatrickMoelands

2007-11-24 08:25

reporter   ~0006378

Last edited: 2007-11-24 08:25

Again, the problem and the workaround:

1) Do a clean installation and reboot.
2) If you run firstboot, nothing goes wrong (graphical screen display fine), reboot again.
3) Graphical login is a complete mess.
4) Switch off and boot again, this time use Grub to go to runlevel 3.
5) Run system-config-display and select proper hardware and resolution.
6) Go to runlevel 5 and there are no problems.

toracat

toracat

2009-09-08 21:08

manager   ~0009897

This is almost 2-yr old and we are at CentOS 5.3 (and will soon be 5.4). Does the problem still exist?
PatrickMoelands

PatrickMoelands

2009-09-08 22:07

reporter   ~0009898

With RHEL5.3, CentOS 5.3 and Scientific Linux 5.3 this problem remains.

Last year I got it filmed using my mobile phone, the movie of the boot sequence (including the graphical problems) can be seen here: http://www.youtube.com/watch?v=qrIRvIUzbtY (the system was running Scientific Linux, but the result with CentOS is the same).

Perhaps good to know is that the people of Fedora nowadays solved this problem simply by adding another option to the grub menu of the installation dvd called "install system with basic video driver" (this option has the following extra boot parameter added: "xdriver=vesa").

2009-10-18 18:46

 

PatrickMoelands

PatrickMoelands

2009-10-18 18:46

reporter   ~0010085

Additional information after testing CentOS 5.4.

When you install on a laptop with an Intel GMA X3100 Gfx chipset, you get a display where things are out of line (like resolutions of 1024x768 on a screen of 1280x800). See the attached image of the desktop (http://bugs.centos.org/file_download.php?file_id=771&type=bug).

It appears that this is a problem related to the system thinking there is an external display connected where it isn't.

More info can be found here:
https://bugzilla.novell.com/show_bug.cgi?id=343858
http://ubuntuforums.org/showthread.php?t=610407

Fortunately, the solution here (too) is that you need to adapt your xorg.conf file. Add the following lines to solve the problem:

- - - - - - - - - - - -
Section "Device"
       Identifier "Videocard0"
       Driver "intel"
       Option "monitor-TV" "TVOutput" <=== this one!!!
EndSection

Section "Monitor" <=== this one!!!
       Identifier "TVOutput" <=== this one!!!
       Option "Ignore" "true" <=== this one!!!
EndSection <=== this one!!!
- - - - - - - - - - - -
Evolution

Evolution

2014-03-05 20:31

administrator   ~0019473

closed due to inactivity. Please re-open if the problem exists with new versions.

Issue History

Date Modified Username Field Change
2007-03-03 11:35 PatrickMoelands New Issue
2007-03-03 11:35 PatrickMoelands Status new => assigned
2007-03-03 11:35 PatrickMoelands File Added: xorg.conf
2007-03-04 09:47 PatrickMoelands Note Added: 0004527
2007-03-04 19:03 PatrickMoelands Note Added: 0004528
2007-03-04 19:03 PatrickMoelands File Added: rhel5-org.conf
2007-03-04 19:04 PatrickMoelands File Added: patrickmoelands-xorg-working.conf
2007-04-02 09:42 JohnnyHughes Note Added: 0004751
2007-04-02 10:12 JohnnyHughes Relationship added related to 0001882
2007-04-03 07:48 PatrickMoelands Note Added: 0004760
2007-04-20 05:00 range Note Added: 0004868
2007-04-20 05:00 range Status assigned => feedback
2007-04-20 14:26 PatrickMoelands Note Added: 0004899
2007-04-20 14:27 PatrickMoelands Note Edited: 0004899
2007-04-20 15:07 PatrickMoelands Note Edited: 0004899
2007-04-20 15:51 range Note Added: 0004901
2007-04-20 15:51 range Product Version 5.0 Beta => 5.0
2007-04-30 02:55 PatrickMoelands Note Added: 0005011
2007-04-30 03:33 range Note Added: 0005012
2007-04-30 03:35 range Note Edited: 0005012
2007-05-01 04:40 PatrickMoelands Note Added: 0005047
2007-05-01 10:38 range Note Added: 0005052
2007-05-01 11:37 PatrickMoelands Note Added: 0005054
2007-05-01 14:27 range Note Added: 0005057
2007-05-01 14:47 PatrickMoelands Note Added: 0005058
2007-05-06 20:04 reloftin Note Added: 0005099
2007-05-07 04:13 range Note Added: 0005100
2007-05-07 04:17 range Note Added: 0005101
2007-05-11 16:14 reloftin Note Added: 0005155
2007-07-27 08:16 PatrickMoelands Note Added: 0005732
2007-11-22 15:53 timverhoeven Note Added: 0006362
2007-11-23 11:33 PatrickMoelands Note Added: 0006366
2007-11-23 17:12 toracat Note Added: 0006370
2007-11-23 17:55 PatrickMoelands Note Added: 0006373
2007-11-23 20:46 arrfab Note Added: 0006376
2007-11-24 08:25 PatrickMoelands Note Added: 0006378
2007-11-24 08:25 PatrickMoelands Note Edited: 0006378
2009-09-08 21:08 toracat Note Added: 0009897
2009-09-08 22:07 PatrickMoelands Note Added: 0009898
2009-10-18 18:46 PatrickMoelands File Added: screenshot-with-c53-xorg.png
2009-10-18 18:46 PatrickMoelands Note Added: 0010085
2014-03-05 20:31 Evolution Note Added: 0019473
2014-03-05 20:31 Evolution Status feedback => closed