2017-04-30 20:43 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001722CentOS-4Missing Componentpublic2013-03-23 18:55
Reporterkbsingh@karan.org 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionsuspended 
Product Version4.4 
Target VersionFixed in Version 
Summary0001722: Provide a downloadable vmware-image, prebuilt and updated
DescriptionWe should be able to provide a few vmware images, with various install options, EG:
1. CentOS-4 Web Server, with LAMP preinstalled
2. CentOS-4 Gnome Desktop
3. CentOS-4 Minimal Install
TagsNo tags attached.
Attached Files

-Relationships
related to 0004779new CentOS-5 Provide OVA-format appliance for deployment on VMware ESXi, VirtualBox, etc. 
+Relationships

-Notes

~0005897

tru (administrator)

uploading now to:
http://dev.centos.org/~tru/vmware/centos-4/

CentOS-4.5 as of 2007/08/23 i386/x86_64
root is the only user, password is "centos" without the quotes.
remote ssh enable.
Minimal and LAMP version are text mode, gnome version is graphical by default.

~0005899

toracat (manager)

I have installed the minimal version on a VMware server. Worked fine. It will be nice if you prepare these images using the C4 100Hz kernel which was built *just for you* :)

Also I assume, now that C5 is out, they should be added to the list...

Akemi

~0005911

tru (administrator)

ok :)

I am adding the 100Hz kernel to the images and make them default, leaving both choice available.

I will also do the c5 versions with the 100HZ too.

~0005917

tru (administrator)

uploading the CentOS-5 version with the 100Hz kernel as default
http://dev.centos.org/~tru/vmware/centos-5/

the CentOS-4 versions have been updated (RHSA for tar) and uploading too
(100Hz kernel are now the default)

I will remove the previous version currently in http://dev.centos.org/~tru/vmware/centos-4/old when the upload is finished to make so space on the server.

~0005918

gbailey (reporter)

I think having a VMware image available for download is a great thing. I have a couple of suggestions/comments about the minimal image I downloaded (and probably applies to the other ones, too):

- The /etc/ssh/ssh_host_* files should probably be removed from the image so that they can be regenerated by the individual virtual machines at startup time

- If you remove the uuid.location, uuid.bios, and ethernet0.generatedAddress lines from the .vmx file, the user won't be prompted to Keep/Create an identifier the first time they boot the image.

- If you modify the floppy drive to "Auto Detect" (instead of /dev/fd0), it might improve usage for people who are using a Windows host (not that I would care, but someone might...)

- I've found that for Linux-based virtual machines I've created, if I create an additional hard drive, copy the partition table over to the new drive, format the partitions, and then rsync the data from the old -> new disks (with the "-H" option), I can significantly reduce the size of the .vmdk file -- you get to clean up the disk space used by the old files which have been deleted from the ext2 filesystem(s). When I did this to your CentOS-4.i386.vmdk file, it was reduced from 945029120 bytes to 780206080 bytes. When I recreated the .zip file with the entire virtual machine, my resulting .zip file (using your VMware image) was reduced from 324299443 bytes to 235201780 bytes!

Would these VMware images be available from the main download page eventually?

~0005920

toracat (manager)

The last comment reminded me of something. The 100Hz kernel will be eventually made available from the CentOS repo. But until that happens, kernel-devel must be included for the 100Hz version for those who want to install vmware-tools. Either that or give a pointer to the location of the -devel rpm.

Akemi

~0005921

tru (administrator)

kernel-devel for the 100HZ and "generic" kernel are provided. :)

good poins from gbailey:
- ssh keys will be removed on the next version
- vmx uploaded without uuid.location, uuid.bios, and ethernet0.generatedAddress
- virtual floppy fixup
- shrinking vmdk: that has to be automated somehow (sfdisk + rsync -aPHSv) (cf: kickstart/rescue scripts). Currently the vmdk files are "defrag" before being zipped

~0005922

toracat (manager)

Sorry I spoke too soon. This time I installed the x86_64, lamp version and indeed -devel was there.

Akemi

~0005964

tru (administrator)

- cloning script tested and "vmdk shrinked" uploaded.
- floppy: auto-detect
- no ssh keys (will be generated on 1st boot)
- vmx without ethernet id (kudzu will ask for config change), and bios id

The size different is mostly noticeable for CentOS-4.
size (kb) version:
5497372 c4-20070827
4011832 c4-20070905
3350728 c5-20070830
3362684 c5-20070905

I will redo the images with the upcoming kernel-vm and the latest RHSA.

~0005965

toracat (manager)

Last edited: 2007-09-24 21:15

A complete set of the latest kernel-vm (2.6.9-55.0.6.EL.i686) is available from http://www.scripps.edu/mem/biochem/ayagi/centos/kernels/kernel-vm/4/ if you like to have them now. This is the kernel update that came out a couple of days ago. The "official" CentOS version must wait until whoever in charge build them. I have submitted the srpms to z00dax and hughesjr. So far, those I built have been running fine on both i386 and x86_64 systems.

Akemi

EDIT: The above url is closed because the latest version of kernel-vm is now available from CentOS testing at http://dev.centos.org/centos/4/testing

~0005966

toracat (manager)

Last edited: 2007-09-24 21:16

Just in case you'd like to use the kernel-vm rpms for C5, I have uploaded them to the same place (replace the 4 with a 5). This is the latest version 2.6.18-8.1.8 . Again, someone has to work on providing the "official" release.

Akemi

EDIT: The above url is closed because the latest version of kernel-vm is now available from CentOS testing at http://dev.centos.org/centos/5/testing

~0006192

gbailey (reporter)

Two more quick suggestions for consideration:

If the /etc/sysconfig/hwconf file is removed or zeroed out before the image is made, then the first boot will not prompt the user to remove a PCnet device and then add a PCnet device. kudzu appears to regenerate the hwconf file if it is empty or non-existent. The current hwconf file has the MAC address that was autogenerated when tru made the image.

Also, the .vmx file does not have the execute bit set and VMware Server complains if this is the case... can a "chmod +x Centos-4.i386.vmx" be done right before the zip file(s) is made?

~0006248

jawildman (reporter)

Do you have a set of scripts, howto's or tips for generating these? Or is it just a matter of crafting one and then tarring up the directory??

Thanks.

Jim

~0006364

tru (administrator)

/etc/sysconfig/hwconf deleted and chmod +x done for >= 2007/11/20 versions

the next releases will be for 4.6 and 5.1 :)

~0006403

gbailey (reporter)

tru,

Are you doing all of the install and modifications using kickstart files? If so, I think it'd be a good reference to post the various kickstart files as attached files to this bug and/or make them available elsewhere.

I'm contemplating using some of the tips posted here to facilitate performing a "sysprep" kind of operation on an installed virtual machine and would be curious to see how you're accomplishing the steps outlined here, especially where you've automated them...

I've registered a project on SourceForge (vmprep) which I intend to use to document these workarounds, as well as describing how to "reinitialize" certain Linux configuration files to make the system appear as if it's just been installed.

thanks!
Greg

~0006418

tru (administrator)

> Are you doing all of the install and modifications using kickstart files?
...

I will when I get so time to write it down. Probably in the virtualisation SIG/centos-virt mailing list.

>I'm contemplating
...

plain scripts, will document and publish them too. nothing magic :)

>I've registered a project on SourceForge (vmprep)...
why bother? you only need a kickstart script + boot.iso to make a vm.
or trust the provided vm...

more discussion on the centos-virt ml, here is not the proper place, imho. :)

~0006562

kbsingh@karan.org (administrator)

Can we disable remote login ?

I can understand there might be some implications of this on a remote headless machine where it might not be possible to get console, but for thos instances we can perhaps enable a serial console interface using a pipe or a virtual ttySX and provide instructions to users who cant get to the normal vmware console, on howto use the serial console instead ? However, I dont want to create more work if there is no real need, so just asking for ideas and opinions.

~0006563

larstr (reporter)

I think the best user experience would have been gained if there was an interactive dialog during the first startup that asked for new root password before starting the ssh daemon. This dialog could also include questions about networking and a normal user. The vmware provided viperltoolkit appliance has similar questions about networking and root password and can be found here: http://www.vmware.com/download/download.do?downloadGroup=VI-PT

Lars

~0006682

tru (administrator)

4.6 and 5.1 released :)

about the serial console: the end user has many choices how the way to set it up...

He just need to add it in the vmware hardware and append 'console=ttyS0' on the grub entry. Kudzu will setup the rest (inittab and /etc/securettty).

about the remote access: if one doesn't want it he just need to start
single user (append '1') on the grub menu and
#/sbin/chkconfig sshd off
# exit

still on the TODO list: howto (ks.cfg files) and cloning scripts

~0008868

larstr (reporter)

It would probably be a good idea to provide these images in .ovf format as it's more portable and also meant for the purpose of moving disk images to different platforms (also other's than VMware).

All newer VMware products have support for the ovf format.

http://en.wikipedia.org/wiki/Open_Virtual_Machine_Format
http://www.vmware.com/pdf/ovf_whitepaper_specification.pdf
http://www.vmware.com/pdf/ovf_tool.pdf

I also think it would benefit the project if these VMs were submitted to the VMware Virtual Appliance Marketplace (with a link back to the download page): http://www.vmware.com/appliances/directory/

Lars

~0016893

tigalch (manager)

CentOS4 is EOL
+Notes

-Issue History
Date Modified Username Field Change
2007-03-03 21:17 kbsingh@karan.org New Issue
2007-03-03 21:17 kbsingh@karan.org Status new => assigned
2007-08-24 21:07 tru Note Added: 0005897
2007-08-25 05:20 toracat Note Added: 0005899
2007-08-27 10:21 tru Note Added: 0005911
2007-08-27 15:57 tru Note Added: 0005917
2007-08-27 16:07 gbailey Note Added: 0005918
2007-08-27 16:34 toracat Note Added: 0005920
2007-08-27 16:53 tru Note Added: 0005921
2007-08-28 06:06 toracat Note Added: 0005922
2007-09-06 13:27 tru Note Added: 0005964
2007-09-06 13:41 toracat Note Added: 0005965
2007-09-06 16:05 toracat Note Added: 0005966
2007-09-24 21:15 toracat Note Edited: 0005965
2007-09-24 21:16 toracat Note Edited: 0005966
2007-10-25 15:49 gbailey Note Added: 0006192
2007-11-07 02:46 jawildman Note Added: 0006248
2007-11-22 18:21 tru Note Added: 0006364
2007-11-26 21:44 gbailey Note Added: 0006403
2007-11-27 18:59 tru Note Added: 0006418
2007-12-16 02:21 kbsingh@karan.org Note Added: 0006562
2007-12-16 17:16 larstr Note Added: 0006563
2008-01-10 13:59 tru Note Added: 0006682
2009-03-02 14:10 larstr Note Added: 0008868
2011-03-25 21:25 toracat Relationship added related to 0004779
2013-03-23 18:55 tigalch Note Added: 0016893
2013-03-23 18:55 tigalch Status assigned => closed
2013-03-23 18:55 tigalch Resolution open => suspended
+Issue History