View Issue Details

IDProjectCategoryView StatusLast Update
0017251CentOS-7kernelpublic2020-09-03 23:53
Reportermrolink 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformCentosOS7OS Version7.7
Product Version7.7-1908 
Target VersionFixed in Version 
Summary0017251: Kernel panic at boot after upgrading kernel to version 3.10.0-1062.18.1.el7.x86_64
DescriptionHi,

We have a big enviroment with multiple Centos 7 Servers. We have als installed a new Hyper V environment where the VM do there thing. The problem is that kernel version 3.10.0-1062.18.1.el7.x86_64 doesn't boot and gives a kernel panic. If i switch back to kernel: 3.10.0-1062.9.1.el7.x86_64 it boots fine.

See attachment for the panic and every time it boots with the kernel it crashes. This is breaking our patch round.
Steps To ReproduceInstall hyper V with:

Microsoft Windows Server 2019 Datacenter
Hyper-V version V3.

Upgrade kernel of VM running centos 7.7 from kernel 3.10.0-1062.9.1.el7.x86_64 to kernel 3.10.0-1062.18.1.el7.x86_64. After a reboot the server will not boot anymore. See attachment.
Additional InformationClosing as 'not a bug'.
TagsNo tags attached.
abrt_hash
URL

Activities

mrolink

mrolink

2020-04-15 10:00

reporter  

hypervissuelinuxkernel.png (135,904 bytes)
hypervissuelinuxkernel.png (135,904 bytes)
ManuelWolfshant

ManuelWolfshant

2020-04-15 10:53

manager   ~0036692

Unfortunately your pic does not include the first lines of the panic message, where the real cause is usually mentioned.
Anyway, since CentOS 7.8 ( via the CR repository of 7.7 ) is on the market for a week already, please test using kernel 3.10.0-1127.el7.x86_64 which is included in it. You can do that by using yum update --enablerepo=cr ( or even yum update kernel --enablerepo=cr if you are willing to risk a bit of cherry picking, a process which is not really supported though even if it is possible )
jalbrizio

jalbrizio

2020-08-31 16:52

reporter   ~0037610

Hi,
I am seeing the same issue, I am using centos7.8. I start with kernel 3.10.0-1062.9.1, then I upgraded to kernel 3.10.0-1127.19.1 and my system will not boot using the new kernel. if I choose the old kernel from the grub menu it boots fine. this is my pre-production test machine using Virtualbox.

unnamed.jpg (57,990 bytes)
unnamed.jpg (57,990 bytes)
TrevorH

TrevorH

2020-08-31 17:03

manager   ~0037611

Both screenshots here look like the usual crash you get when yum has been interrupted during the kernel package install and it has half installed the kernel. In this situation then kernel itself is installed and added to grub but yum generates the initramfs file for it in the cleanup phase so if it's interrupted between those two then you end up with a kernel installed that has no initramfs.

Either remove that kernel and reinstall it or `yum reinstall kernel-3.10.0-1127.19.1.el7` or run dracut -f --kvers 3.10.0-1127.19.1.el7 (or some variation on that, not tested so please test before use!). Obviously you will need to boot an older kernel to do that and then reboot into the new one again.
jalbrizio

jalbrizio

2020-08-31 19:12

reporter   ~0037612

I reverted from a snapshot. did an upgrade with --exclude=kernel* and --exclude=linux-firmware*.rebooted with no issues.
Next, I made a snapshot and I upgraded with only --exclude=linux-firmware* (this was a suggestion I found in another thread) and it booted properly.
I made a snapshot again, then upgraded just the firmware. I rebooted with no issues.
It looks like you are correct TrevorH it was that the new kernel installation was interrupted. thanks. :)

Issue History

Date Modified Username Field Change
2020-04-15 10:00 mrolink New Issue
2020-04-15 10:00 mrolink File Added: hypervissuelinuxkernel.png
2020-04-15 10:53 ManuelWolfshant Note Added: 0036692
2020-08-31 16:52 jalbrizio File Added: unnamed.jpg
2020-08-31 16:52 jalbrizio Note Added: 0037610
2020-08-31 17:03 TrevorH Note Added: 0037611
2020-08-31 19:12 jalbrizio Note Added: 0037612
2020-09-03 23:53 toracat Status new => resolved
2020-09-03 23:53 toracat Resolution open => no change required
2020-09-03 23:53 toracat Description Updated View Revisions
2020-09-03 23:53 toracat Steps to Reproduce Updated View Revisions
2020-09-03 23:53 toracat Additional Information Updated View Revisions