View Issue Details

IDProjectCategoryView StatusLast Update
0017271SCLo[All Projects] generalpublic2020-04-21 08:41
Reporterhhorak 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Summary0017271: nss_wrapper missing on the mirrors
DescriptionThis is the original ticket that resulted in sclo7-common-release tagged packages being on the CentOS mirror: https://bugs.centos.org/view.php?id=11158

From some reason, nss_wrapper and source-to-image packages that are tagged with sclo7-common-release disappeared from the mirror repos (http://mirror.centos.org/centos/7/sclo/x86_64/rh/).

Please, add it back, we need the nss_wrapper at least to be able to build the CentOS based container images.
Steps To ReproduceLook for nss_wrapper package in http://mirror.centos.org/centos/7/sclo/x86_64/rh/.
TagsNo tags attached.

Activities

arrfab

arrfab

2020-04-20 10:52

administrator   ~0036723

per discussion with Jstanek on irc, there was a list of maintained collections to include in new signing process.
nss_wrapper *wasn't* in a collection itself, so not identified. It was then added and should be going out to mirrors now
arrfab

arrfab

2020-04-20 11:46

administrator   ~0036724

Jstanek verified again the list of tags that are supposed to be landing on mirror network after those were signed.
That means that nss_wrapper is on its way to mirror network.
Now my question : as you have -testing (which also was suffering from this), don't you have some kind of CI/validation tests before your promote exact same content (including so pkgs) to -release ?
jstanek

jstanek

2020-04-20 11:56

manager   ~0036725

We do; however, our current process actually checks the test results when pushing (tagging) new content; and in this case, a dependency was "stolen" from packages already tagged, so it slipped.
Also, since the tests are currently being adapted to work with the new process, this particular failure could also just fall through the cracks.

Issue History

Date Modified Username Field Change
2020-04-20 10:20 hhorak New Issue
2020-04-20 10:46 arrfab Project Buildsys => SCLo
2020-04-20 10:46 arrfab Category community buildsys => general
2020-04-20 10:52 arrfab Note Added: 0036723
2020-04-20 11:46 arrfab Status new => resolved
2020-04-20 11:46 arrfab Resolution open => fixed
2020-04-20 11:46 arrfab Note Added: 0036724
2020-04-20 11:56 jstanek Note Added: 0036725