View Issue Details

IDProjectCategoryView StatusLast Update
0017273AltArch - armhfp[CentOS-7] libxsltpublic2020-04-20 15:56
Reporterzoran 
PriorityhighSeveritycrashReproducibilityalways
Status newResolutionopen 
PlatformarmOScentos7OS Version
Product Version[CentOS-7] 7.7-1908 
Target VersionFixed in Version 
Summary0017273: libxslt-devel can't install
Description[root@center ~]# yum install libxslt-devel
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.huaweicloud.com
 * centos-kernel: mirrors.huaweicloud.com
 * extras: mirrors.huaweicloud.com
 * updates: mirrors.huaweicloud.com
正在解决依赖关系
--> 正在检查事务
---> 软件包 libxslt-devel.armv7hl.0.1.1.28-5.el7 将被 安装
--> 正在处理依赖关系 libxslt = 1.1.28-5.el7,它被软件包 libxslt-devel-1.1.28-5.el7.armv7hl 需要
--> 正在处理依赖关系 pkgconfig(libxml-2.0),它被软件包 libxslt-devel-1.1.28-5.el7.armv7hl 需要
--> 正在处理依赖关系 libxslt.so.1,它被软件包 libxslt-devel-1.1.28-5.el7.armv7hl 需要
--> 正在处理依赖关系 libgcrypt-devel,它被软件包 libxslt-devel-1.1.28-5.el7.armv7hl 需要
--> 正在处理依赖关系 libexslt.so.0,它被软件包 libxslt-devel-1.1.28-5.el7.armv7hl 需要
--> 正在检查事务
---> 软件包 libgcrypt-devel.armv7hl.0.1.5.3-14.el7 将被 安装
--> 正在处理依赖关系 libgpg-error-devel,它被软件包 libgcrypt-devel-1.5.3-14.el7.armv7hl 需要
---> 软件包 libxml2-devel.armv7hl.0.2.9.1-6.el7_2.3 将被 安装
--> 正在处理依赖关系 libxml2 = 2.9.1-6.el7_2.3,它被软件包 libxml2-devel-2.9.1-6.el7_2.3.armv7hl 需要
--> 正在处理依赖关系 xz-devel,它被软件包 libxml2-devel-2.9.1-6.el7_2.3.armv7hl 需要
---> 软件包 libxslt.armv7hl.0.1.1.28-5.el7 将被 安装
--> 正在检查事务
---> 软件包 libgpg-error-devel.armv7hl.0.1.12-3.el7 将被 安装
---> 软件包 libxml2-devel.armv7hl.0.2.9.1-6.el7_2.3 将被 安装
--> 正在处理依赖关系 libxml2 = 2.9.1-6.el7_2.3,它被软件包 libxml2-devel-2.9.1-6.el7_2.3.armv7hl 需要
---> 软件包 xz-devel.armv7hl.0.5.2.2-1.el7 将被 安装
--> 解决依赖关系完成
错误:软件包:libxml2-devel-2.9.1-6.el7_2.3.armv7hl (base)
          需要:libxml2 = 2.9.1-6.el7_2.3
          已安装: libxml2-2.9.1-6.el7.3.armv7hl (@base)
              libxml2 = 2.9.1-6.el7.3
          可用: libxml2-2.9.1-6.el7_2.3.armv7hl (base)
              libxml2 = 2.9.1-6.el7_2.3
 您可以尝试添加 --skip-broken 选项来解决该问题
** 发现 7 个已存在的 RPM 数据库问题, 'yum check' 输出如下:
chkconfig-1.7.4-1.el7.armv7hl 是 chkconfig-1.3.61-5.el7.armv7hl 的副本
grep-2.20-3.el7.armv7hl 是 grep-2.20-2.el7.armv7hl 的副本
libffi-3.0.13-18.el7.armv7hl 是 libffi-3.0.13-16.el7.armv7hl 的副本
libgcrypt-1.5.3-14.el7.armv7hl 是 libgcrypt-1.5.3-12.el7.1.armv7hl 的副本
libnl3-3.2.28-4.el7.armv7hl 是 libnl3-3.2.21-10.el7.armv7hl 的副本
pcre-8.32-17.el7.armv7hl 是 pcre-8.32-15.el7.1.armv7hl 的副本
xz-libs-5.2.2-1.el7.armv7hl 是 xz-libs-5.1.2-9alpha.el7.armv7hl 的副本
TagsRaspberryPi2

Activities

zoran

zoran

2020-04-20 15:56

reporter   ~0036729

[root@center ~]# yum install libxslt-devel
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.huaweicloud.com
 * centos-kernel: mirrors.huaweicloud.com
 * extras: mirrors.huaweicloud.com
 * updates: mirrors.huaweicloud.com
gitlab_gitlab-ee/armhfp/signature | 862 B 00:00:00
gitlab_gitlab-ee/armhfp/signature | 951 B 00:00:00 !!!
gitlab_gitlab-ee-source/signature | 862 B 00:00:00
gitlab_gitlab-ee-source/signature | 951 B 00:00:00 !!!
Resolving Dependencies
--> Running transaction check
---> Package libxslt-devel.armv7hl 0:1.1.28-5.el7 will be installed
--> Processing Dependency: libxslt = 1.1.28-5.el7 for package: libxslt-devel-1.1.28-5.el7.armv7hl
--> Processing Dependency: pkgconfig(libxml-2.0) for package: libxslt-devel-1.1.28-5.el7.armv7hl
--> Processing Dependency: libxslt.so.1 for package: libxslt-devel-1.1.28-5.el7.armv7hl
--> Processing Dependency: libgcrypt-devel for package: libxslt-devel-1.1.28-5.el7.armv7hl
--> Processing Dependency: libexslt.so.0 for package: libxslt-devel-1.1.28-5.el7.armv7hl
--> Running transaction check
---> Package libgcrypt-devel.armv7hl 0:1.5.3-14.el7 will be installed
--> Processing Dependency: libgpg-error-devel for package: libgcrypt-devel-1.5.3-14.el7.armv7hl
---> Package libxml2-devel.armv7hl 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7_2.3 for package: libxml2-devel-2.9.1-6.el7_2.3.armv7hl
--> Processing Dependency: xz-devel for package: libxml2-devel-2.9.1-6.el7_2.3.armv7hl
---> Package libxslt.armv7hl 0:1.1.28-5.el7 will be installed
--> Running transaction check
---> Package libgpg-error-devel.armv7hl 0:1.12-3.el7 will be installed
---> Package libxml2-devel.armv7hl 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7_2.3 for package: libxml2-devel-2.9.1-6.el7_2.3.armv7hl
---> Package xz-devel.armv7hl 0:5.2.2-1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: libxml2-devel-2.9.1-6.el7_2.3.armv7hl (base)
           Requires: libxml2 = 2.9.1-6.el7_2.3
           Installed: libxml2-2.9.1-6.el7.3.armv7hl (@base)
               libxml2 = 2.9.1-6.el7.3
           Available: libxml2-2.9.1-6.el7_2.3.armv7hl (base)
               libxml2 = 2.9.1-6.el7_2.3
 You could try using --skip-broken to work around the problem
** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
chkconfig-1.7.4-1.el7.armv7hl is a duplicate with chkconfig-1.3.61-5.el7.armv7hl
grep-2.20-3.el7.armv7hl is a duplicate with grep-2.20-2.el7.armv7hl
libffi-3.0.13-18.el7.armv7hl is a duplicate with libffi-3.0.13-16.el7.armv7hl
libgcrypt-1.5.3-14.el7.armv7hl is a duplicate with libgcrypt-1.5.3-12.el7.1.armv7hl
libnl3-3.2.28-4.el7.armv7hl is a duplicate with libnl3-3.2.21-10.el7.armv7hl
pcre-8.32-17.el7.armv7hl is a duplicate with pcre-8.32-15.el7.1.armv7hl
xz-libs-5.2.2-1.el7.armv7hl is a duplicate with xz-libs-5.1.2-9alpha.el7.armv7h

Issue History

Date Modified Username Field Change
2020-04-20 15:51 zoran New Issue
2020-04-20 15:53 zoran Tag Attached: RaspberryPi2
2020-04-20 15:56 zoran Note Added: 0036729