View Issue Details

IDProjectCategoryView StatusLast Update
0017293CentOS-7yumpublic2020-11-17 14:24
Reporterjpatel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version7.7-1908 
Target VersionFixed in Version 
Summary0017293: yumbuilddep has incorrect path for extras repo
DescriptionWhen using the official `centos:7` docker image from dockerhub, the extras repo path is broken and produces a 404 error.

 
Steps To Reproduce1. Run the docker image : `docker run -it --rm centos:7 bash`
2. Run the yumbuilddep comand: `yum-builddep kernel`

You should see the failure as shown below:

```
 → docker run -it --rm centos:7 bash
[root@8539266088fe /]#
[root@8539266088fe /]#
[root@8539266088fe /]# yum-builddep kernel
Loaded plugins: fastestmirror, ovl
Enabling base-source repository
Enabling extras-source repository
Enabling updates-source repository
base | 3.6 kB 00:00
base-source | 2.9 kB 00:00
extras | 2.9 kB 00:00
http://vault.centos.org/centos/7/extras/Source/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

failure: repodata/repomd.xml from extras-source: [Errno 256] No more mirrors to try.
http://vault.centos.org/centos/7/extras/Source/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
```
Additional InformationIn order to workaround the issue had to use `yum-builddep --disablerepo=extras kernel`
TagsNo tags attached.
abrt_hash
URL

Activities

jpatel

jpatel

2020-04-27 23:00

reporter   ~0036781

Some additional information:

It looks like http://vault.centos.org/7.8.2003/ was updated last week and there are some locations where there is no more repodata. Such as here: http://vault.centos.org/7.8.2003/extras/Source/ .
In the previous version, repodata existed: http://vault.centos.org/7.7.1908/extras/Source/repodata/
ManuelWolfshant

ManuelWolfshant

2020-04-27 23:11

manager   ~0036782

You are correct in your findings. As a side effect of releasing 7.8.2003, a few more directories from vault need supplemental love. The persons in charge were notified.
vminaev8

vminaev8

2020-04-28 09:40

reporter   ~0036788

The same issue while building an RPM:
```
http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

failure: repodata/repomd.xml from centos-sclo-rh-source: [Errno 256] No more mirrors to try.
http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
```

What is the expected time to handle this issue?

As I see this problem keeps repeating:
https://bugs.centos.org/view.php?id=12793
https://bugs.centos.org/view.php?id=14773
https://bugs.centos.org/view.php?id=16423

Who is responsible for such a mess?
ManuelWolfshant

ManuelWolfshant

2020-04-28 10:47

manager   ~0036791

The repodata is now available.

Issue History

Date Modified Username Field Change
2020-04-27 22:55 jpatel New Issue
2020-04-27 23:00 jpatel Note Added: 0036781
2020-04-27 23:11 ManuelWolfshant Note Added: 0036782
2020-04-28 09:40 vminaev8 Note Added: 0036788
2020-04-28 10:47 ManuelWolfshant Status new => closed
2020-04-28 10:47 ManuelWolfshant Resolution open => fixed
2020-04-28 10:47 ManuelWolfshant Note Added: 0036791