View Issue Details

IDProjectCategoryView StatusLast Update
0017337CentOS-8kernel-pluspublic2020-06-19 22:40
Reporterdkeller 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0017337: Enable btrfs module in kernel plus.
DescriptionRedhat has disabled the btrfs module, Please enable this module in Kernel Plus.

CONFIG_BTRFS_FS=m
Steps To ReproduceAs per Upstearm documentation, btrfs was removed.
Additional Informationthis would simplify the migration of systems with a btrfs filesystem
TagsNo tags attached.

Activities

toracat

toracat

2020-05-09 17:07

manager   ~0036906

This will be done in the upcoming 8.2 kernel (4.18.0-193.el8). Config diff is:

@@ -6768,7 +6767,13 @@ CONFIG_XFS_POSIX_ACL=y
 CONFIG_GFS2_FS=m
 CONFIG_GFS2_FS_LOCKING_DLM=y
 # CONFIG_OCFS2_FS is not set
-# CONFIG_BTRFS_FS is not set
+CONFIG_BTRFS_FS=m
+# CONFIG_BTRFS_FS_POSIX_ACL is not set
+# CONFIG_BTRFS_FS_CHECK_INTEGRITY is not set
+# CONFIG_BTRFS_FS_RUN_SANITY_TESTS is not set
+# CONFIG_BTRFS_DEBUG is not set
+# CONFIG_BTRFS_ASSERT is not set
+# CONFIG_BTRFS_FS_REF_VERIFY is not set
 # CONFIG_NILFS2_FS is not set
 # CONFIG_F2FS_FS is not set
 CONFIG_FS_DAX=y
@@ -7663,12 +7668,15 @@ CONFIG_CRC32_SLICEBY8=y
 CONFIG_CRC7=m
 CONFIG_LIBCRC32C=m
 CONFIG_CRC8=m
+CONFIG_XXHASH=m
 # CONFIG_RANDOM32_SELFTEST is not set
 CONFIG_ZLIB_INFLATE=y
 CONFIG_ZLIB_DEFLATE=y
 CONFIG_LZO_COMPRESS=y
 CONFIG_LZO_DECOMPRESS=y
 CONFIG_LZ4_DECOMPRESS=y
+CONFIG_ZSTD_COMPRESS=m
+CONFIG_ZSTD_DECOMPRESS=m
 CONFIG_XZ_DEC=y
 CONFIG_XZ_DEC_X86=y
 CONFIG_XZ_DEC_POWERPC=y
toracat

toracat

2020-05-25 06:04

manager   ~0036983

Enabling btrfs caused build errors. Besides, there will be no security/bug fixes because the source code does not get any updates. Backporting from a newer kernel and maintaining it is beyond what we can do.

Issue History

Date Modified Username Field Change
2020-05-06 14:41 dkeller New Issue
2020-05-09 17:01 toracat Status new => assigned
2020-05-09 17:07 toracat Note Added: 0036906
2020-05-25 06:04 toracat Note Added: 0036983
2020-06-19 22:40 toracat Status assigned => resolved
2020-06-19 22:40 toracat Resolution open => won't fix