View Issue Details

IDProjectCategoryView StatusLast Update
0017430Cloud Instance SIG[All Projects] generalpublic2020-06-25 10:43
Reporterdavdunc 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformAmazon EC2OSCentOSOS Version8
Summary0017430: CentOS8-EC2 image fails to boot due to missing device support on Amazon EC2.
Descriptionhttps://cloud.centos.org/centos/8/x86_64/images/CentOS-8-ec2-8.1.1911-20200113.3.x86_64.qcow2 does not boot due to missing device drivers in the initramfs
using governor menu
[ 0.070176] ACPI: bus type PCI registered
[ 0.071005] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[ 0.072114] PCI: Using configuration type 1 for base access
[ 0.074022] HugeTLB registered 1.00 GiB page size, pre-allocated 0 pages
[ 0.075004] HugeTLB registered 2.00 MiB page size, pre-allocated 0 pages
[ 0.077039] cryptd: max_cpu_qlen set to 1000
[ 0.078051] ACPI: Added _OSI(Module Device)
[ 0.079004] ACPI: Added _OSI(Processor Device)
[ 0.080002] ACPI: Added _OSI(3.0 _SCP Extensions)
[ 0.082006] ACPI: Added _OSI(Processor Aggregator Device)
[ 0.083005] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.084694] ACPI: 2 ACPI AML tables successfully acquired and loaded
[ 0.086109] ACPI: Interpreter enabled
[ 0.087013] ACPI: (supports S0 S4 S5)
[ 0.087929] ACPI: Using IOAPIC for interrupt routing
[ 0.088012] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[ 0.089382] ACPI: Enabled 16 GPEs in block 00 to 0F
[ 0.092062] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
[ 0.093007] acpi PNP0A03:00: _OSC: OS supports [ASPM ClockPM Segments MSI]
[ 0.094009] acpi PNP0A03:00: fail to add MMCONFIG information, can't access extended PCI configuration space under this bridge.
[. . . ]
  Mounting Kernel Configuration File System...
[[0;32m OK [0m] Mounted Kernel Configuration File System.
[[0;32m OK [0m] Started udev Coldplug all Devices.
[[0;32m OK [0m] Reached target System Initialization.
[[0;32m OK [0m] Reached target Basic System.
         Starting dracut initqueue hook...
[ 131.495735] dracut-initqueue[345]: Warning: dracut-initqueue timeout - starting timeout scripts
[. . . ]
[ 194.577635] dracut-initqueue[345]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 194.580743] dracut-initqueue[345]: Warning: Could not boot.
         Starting Setup Virtual Console...
[[0;32m OK [0m] Started Setup Virtual Console.
         Starting Dracut Emergency Shell...
Warning: /dev/disk/by-uuid/f096157e-0314-4a17-86b9-091e155b8b76 does not exist

Generating "/run/initramfs/rdsosreport.txt"


Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

Steps To ReproduceConvert image to raw for import
    # qemu-img convert ./CentOS-8-ec2-8.1.1911-20200113.3.x86_64.qcow2 ./CentOS-8-ec2-8.1.1911-20200113.3.x86_64.raw
Upload to S3 for import
    # aws s3 cp ./CentOS-8-ec2-8.1.1911-20200113.3.x86_64.raw s3://<my_bucket>/
Import the raw image to snapshot
    # aws ec2 import-snapshot --client-token CentOS8 --description "Import Base CentOS8 Image" --disk-container "Description=CentOS-8-ec2-8.1.1911-20200113.3.x86_64.raw,Format=raw,UserBucket={S3Bucket=<my_bucket>,S3Key=disk-images/CentOS-8-ec2-8.1.1911-20200113.3.x86_64.raw}"
Register the image
    # aws ec2 register-image --architecture=x86_64 \
    --virtualization-type hvm \
    --description='CentOS 8 (x86_64) for HVM Instances' \
    --root-device-name '/dev/sda1' \
    --name='CentOS-8-ec2-8.1.1911-20200113.3.x86_64' \
    --ena-support --sriov-net-support simple \
    --block-device-mappings "[{\"DeviceName\": \"/dev/sda1\", \"Ebs\": {\"DeleteOnTermination\":true, \"SnapshotId\":\"snap-0194fe89d00xxxxxx\", \"VolumeSize\":10, \"VolumeType\":\"gp2\"}}]"

Now Launch an instance from the created image.
TagsAWS;AMI

Activities

hpetty

hpetty

2020-06-04 00:17

reporter   ~0037033

It looks like this section of the kickstart file is not being run, or has an error:

echo 'add_drivers+="xen-netfront xen-blkfront "' > /etc/dracut.conf.d/xen.conf
# Rerun dracut for the installed kernel (not the running kernel):
KERNEL_VERSION=$(rpm -q kernel --qf '%{V}-%{R}.%{arch}\n')
dracut -f /boot/initramfs-$KERNEL_VERSION.img $KERNEL_VERSION

This is from: https://git.centos.org/centos/kickstarts/blob/master/f/CentOS-8-EC2.ks

I pulled down the EC2 image from https://cloud.centos.org/centos/8/x86_64/images/

loop back mounted the image, and chroot'd to it. I then ran the above commands. After tearing down the loopback mount, I was able to register an AMI using the updated image, and run the AMI.
arrfab

arrfab

2020-06-04 06:16

administrator   ~0037035

Last edited: 2020-06-04 06:18

View 2 revisions

Yes, and as you saw , it's fixed for 2 months in git, but it's just that there was no cloud image compose (probably now waiting on 8.2.2004) so hopefully that will be fixed soon
Relevant commits :
- https://git.centos.org/centos/kickstarts/c/153a34222b7ac0a14fd30443b8ebeb7e300028c0?branch=master
- https://git.centos.org/centos/kickstarts/c/083d49e590d448eee5f7f758b1c97fca2eb3d42e?branch=master (for aarch64 that needs also EFI part)

davdunc

davdunc

2020-06-18 22:15

reporter   ~0037163

This is resolved with the availability of the 8.2.2004 images.

Issue History

Date Modified Username Field Change
2020-06-03 23:39 davdunc New Issue
2020-06-03 23:39 davdunc Tag Attached: AWS;AMI
2020-06-04 00:17 hpetty Note Added: 0037033
2020-06-04 06:16 arrfab Note Added: 0037035
2020-06-04 06:16 arrfab Status new => acknowledged
2020-06-04 06:18 arrfab Note Edited: 0037035 View Revisions
2020-06-18 22:15 davdunc Note Added: 0037163
2020-06-25 10:43 arrfab Status acknowledged => resolved
2020-06-25 10:43 arrfab Resolution open => fixed