View Issue Details

IDProjectCategoryView StatusLast Update
0017433CentOS-7[All Projects] generalpublic2020-07-07 11:14
Reporterlegrandewen 
PriorityimmediateSeverityblockReproducibilityrandom
Status closedResolutionno change required 
PlatformArmv7OSCentOS Linux release 7.6.1810 OS Version 7.6.1810
Product Version 
Target VersionFixed in Version 
Summary0017433: .Xauthority-c and .Xauthority-l lock files generated after using startx command
DescriptionAt boot, our web application is launched by the command startx ( The startx(1) script is a front-end for xinit(1). The xinit program allows a user to manually start an Xorg display server.) and is displayed on the screen.

But sometimes, we get an error just after a reboot : " timeout in locking authority file /home/prescom/.Xauthority " and the web application can't start anymore (even after few reboot). If we manually launch the web application using startx, we get the error "no protocol specified".

After analysis, two lock file are present in the /home/user folder : .Xauthority-c and .Xauthority-l

 Those files are lock files for .Xauthority, so simply removing them resolves the issue.

We need to know Why and how the lock files are generated ?

Thank you for your support,

Ewen Legrand

Research engineer,

Tel : +33 (0) 7 71 92 75 55 / 02 96 05 76 06
ewen.legrand@prescom.fr
PRESCOM
Rue de Broglie , 22300 LANNION , FRANCE
www.prescom.fr


NB : the xinit command executed is as follows : " xinit /home/prescom/.xinitrc -- -auth /home/prescom/.server.xxxx /usr/bin/X :2 -nocursor "
Steps To Reproducerandom
Additional InformationNB : the xinit command executed is as follows : " xinit /home/prescom/.xinitrc -- -auth /home/prescom/.server.xxxx /usr/bin/X :2 -nocursor "

Link forum solution : https://unix.stackexchange.com/questions/215558/why-am-i-getting-this-message-from-xauth-timeout-in-locking-authority-file-ho
Tags#Centos7, armv7, centos7, serverx, startx, xauthority, xinit, Xorg
abrt_hash
URL

Activities

legrandewen

legrandewen

2020-07-03 07:11

reporter   ~0037294

Hi,
Do you need any other information in order to help you to find an answer ?
Did you find any clue regarding lock file creation ?
Thank you for your support.
Ewen Legrand
legrandewen

legrandewen

2020-07-07 07:44

reporter   ~0037320

NB : Both .Xauthority files are empty (0 byte).
ManuelWolfshant

ManuelWolfshant

2020-07-07 11:14

manager   ~0037322

Since you are not reporting a bug but you are seeking support, I am going to close this bug because the bug tracker is not a support channel. Please seek help in more appropriate venues like CentOS fora, mailing list or IRC.

As a side note, I suspect your application dies leaving around dangling lock files. But it's just an educated guess, the problem might be completely different

Issue History

Date Modified Username Field Change
2020-06-05 06:40 legrandewen New Issue
2020-06-05 06:40 legrandewen Tag Attached: #Centos7
2020-06-05 06:45 legrandewen Tag Attached: centos7
2020-06-05 06:45 legrandewen Tag Attached: Xorg
2020-06-05 06:45 legrandewen Tag Attached: armv7
2020-06-05 06:45 legrandewen Tag Attached: serverx
2020-06-05 06:45 legrandewen Tag Attached: startx
2020-06-05 06:45 legrandewen Tag Attached: xinit
2020-06-05 06:45 legrandewen Tag Attached: xauthority
2020-06-11 21:41 tru Project administration => CentOS-7
2020-06-11 21:41 tru Category mirrors => general
2020-07-03 07:11 legrandewen Note Added: 0037294
2020-07-07 07:44 legrandewen Note Added: 0037320
2020-07-07 11:14 ManuelWolfshant Status new => closed
2020-07-07 11:14 ManuelWolfshant Resolution open => no change required
2020-07-07 11:14 ManuelWolfshant Note Added: 0037322