View Issue Details

IDProjectCategoryView StatusLast Update
0017449CentOS-7ImageMagickpublic2020-06-11 22:01
Reportermed 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version7.8-2003 
Target VersionFixed in Version 
Summary0017449: imagemagick/convert fails to convert ps to pdf in centos 7.8 systems
Descriptionlibpng warning: Application built with libpng-1.6.26 but running with 1.5.13
libpng warning: Application built with libpng-1.6.26 but running with 1.5.13
convert: Postscript delegate failed `[ghostscript library 9.22] -sstdout=%stderr -dQUIET -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 '-sDEVICE=pngalpha' -dTextAlphaBits=4 -dGraphicsAlphaBits=4 '-r72x72' -g261x801 '-sOutputFile=/tmp/magick-151216nfrVRblDe8Eu%d' '-f/tmp/magick-151216nPphX_FYZviO' '-f/tmp/magick-151216W1P7nAzoi9V7'': Error: /VMerror in --showpage--
VM status: 1 4893411 6230368
Current allocation mode is local
Current file position is 189995
GPL Ghostscript 9.22: Unrecoverable error, exit code 1
 @ error/ghostscript-private.h/InvokeGhostscriptDelegate/171.
convert: Postscript delegate failed `[ghostscript library 9.22] -sstdout=%stderr -dQUIET -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 '-sDEVICE=pngalpha' -dTextAlphaBits=4 -dGraphicsAlphaBits=4 '-r72x72' -g261x801 '-sOutputFile=/tmp/magick-151216nfrVRblDe8Eu%d' '-f/tmp/magick-151216nPphX_FYZviO' '-f/tmp/magick-151216W1P7nAzoi9V7' -c showpage': Error: /VMerror in --showpage--
VM status: 1 4893411 6230368
Current allocation mode is local
Current file position is 189995
GPL Ghostscript 9.22: Unrecoverable error, exit code 1
 @ error/ghostscript-private.h/InvokeGhostscriptDelegate/171.
convert: no images defined `-' @ error/convert.c/ConvertImageCommand/3235.
Steps To Reproducewhenever you convert from ps to pdf on a fresh or updated centos 7.8 system using convert command :
convert test.ps test.pdf
TagsNo tags attached.
abrt_hash
URL

Activities

med

med

2020-06-11 20:41

reporter   ~0037075

Release: Centos 7.8.2003

Packages installed :
libpng-1.5.13-7.el7_2.x86_64
ghostscript-9.25-2.el7_7.3.x86_64
ImageMagick-c++-devel-6.9.10.68-3.el7.x86_64
ImageMagick-perl-6.9.10.68-3.el7.x86_64
ImageMagick-devel-6.9.10.68-3.el7.x86_64
ImageMagick-6.9.10.68-3.el7.x86_64
ImageMagick-c++-6.9.10.68-3.el7.x86_64
JohnnyHughes

JohnnyHughes

2020-06-11 20:58

administrator   ~0037076

There is no libpng-1.6.26 in CentOS-7.8 .. where did you get that version. I would reinstall libpng-1.5.13-7.el7_2 which is the latest CentOS-7 version.
JohnnyHughes

JohnnyHughes

2020-06-11 20:59

administrator   ~0037077

Last edited: 2020-06-11 21:05

View 3 revisions

Or maybe the ps file was built with a newer version of libpng?

The versions you listed are correct .. but that error means that something on your system is using or did use the newer version of libpng.

In fact .. it seems the binary ghostscript run is "GPL Ghostscript 9.22: Unrecoverable error, exit code 1"
 .. not 9.25 that is in CentOS 7.8

med

med

2020-06-11 21:10

reporter   ~0037078

@JohnnyHughes. I have generated a new ps on the same system then I tried to convert it to pdf but I got the same error.
tru

tru

2020-06-11 21:48

administrator   ~0037079

I can't reproduce your claims and I suspect that you have a side installed ghostscript 9.22 in your PATH.

[tru@elitebook840g3 ~]$ rpm -qa libpng ghostscript ImageMagick\*|sort
ghostscript-9.25-2.el7_7.3.x86_64
ImageMagick-6.9.10.68-3.el7.x86_64
libpng-1.5.13-7.el7_2.i686
libpng-1.5.13-7.el7_2.x86_64

[tru@elitebook840g3 ~]$ wget -O tiger.eps 'http://git.ghostscript.com/?p=ghostpdl.git;a=blob_plain;f=examples/tiger.eps;hb=HEAD'
--2020-06-11 23:46:41-- http://git.ghostscript.com/?p=ghostpdl.git;a=blob_plain;f=examples/tiger.eps;hb=HEAD
Resolving git.ghostscript.com (git.ghostscript.com)... 184.73.189.105
Connecting to git.ghostscript.com (git.ghostscript.com)|184.73.189.105|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/postscript]
Saving to: ‘tiger.eps’

    [ <=> ] 78,599 413KB/s in 0.2s

2020-06-11 23:46:42 (413 KB/s) - ‘tiger.eps’ saved [78599]

[tru@elitebook840g3 ~]$ md5sum tiger.eps
b0f1678ed18bc9f1ce834dea3c81f9d1 tiger.eps
[tru@elitebook840g3 ~]$ type convert gs
convert is hashed (/usr/bin/convert)
gs is /usr/bin/gs
[tru@elitebook840g3 ~]$ convert tiger.eps tiger.pdf
[tru@elitebook840g3 ~]$ echo $?
0
med

med

2020-06-11 22:00

reporter   ~0037081

yeah, I think I found the issue, some other Ghostscript packages were installed on the system. This can be closed.
Thanks.

Issue History

Date Modified Username Field Change
2020-06-11 20:36 med New Issue
2020-06-11 20:41 med Note Added: 0037075
2020-06-11 20:58 JohnnyHughes Note Added: 0037076
2020-06-11 20:59 JohnnyHughes Note Added: 0037077
2020-06-11 21:03 JohnnyHughes Note Edited: 0037077 View Revisions
2020-06-11 21:05 JohnnyHughes Note Edited: 0037077 View Revisions
2020-06-11 21:10 med Note Added: 0037078
2020-06-11 21:48 tru Note Added: 0037079
2020-06-11 22:00 med Note Added: 0037081
2020-06-11 22:01 ManuelWolfshant Status new => closed
2020-06-11 22:01 ManuelWolfshant Resolution open => no change required