View Issue Details

IDProjectCategoryView StatusLast Update
0017465CentOS-8grub2public2020-06-16 18:32
Reporterluiseb 
PriorityurgentSeverityblockReproducibilityalways
Status newResolutionopen 
Product Version8.1.1911 
Target VersionFixed in Version 
Summary0017465: Windows wont appear at grub menu at boot time
DescriptionWhen installing centos 8 stream, the installation installs grub boot and its menu but it doesnt recognize the windows partition so you will loose your windows system until this problem is solved.
The windows partition is there with all the data, actually after installing epel repo and ntfs-3g you can mount your windows partition even you cant boot it
Quite annoying problem since it totally stops your windows operation for your business (remember that we still need windows for some compatibility reasons for our job)
Hit Im using windows 10 and centos 8 stream. When I installed and centos 7 I never had this problem.
Steps To ReproduceInstall centos 8 stream
Take the actions required afterwards (dnf update etc..) from official centos web page. Please see: https://forums.centos.org/viewtopic.php?f=9&t=72492
You can install epel repo
You can install ntfs-eg
Reboot
You will just see centos 8 at your grub boot menu
Boot and login
run grub2-mkconfig
you will see that it will never find the windows 10 OS so it will never be included in your grub dual-boot menu
you can even mount your windows partition in centos 8 stream and check that your OS is there and can navigate it
reboot
The same problem
The fdisk -l output for /dev/sda
Disposit. Comienzo Final Sectores Tamaño Tipo
/dev/sda1 2048 2099199 2097152 1G Entorno de recuperación de Windows
/dev/sda2 2099200 2303999 204800 100M Sistema EFI
/dev/sda3 2304000 2566143 262144 128M Reservado para Microsoft
/dev/sda4 2566144 981327060 978760917 466,7G Datos básicos de Microsoft
/dev/sda5 981327872 983152639 1824768 891M Entorno de recuperación de Windows
/dev/sda6 983152640 985249791 2097152 1G Sistema de ficheros de Linux
/dev/sda7 985249792 1897867263 912617472 435,2G Sistema de ficheros de Linux
/dev/sda8 1897867264 1931421695 33554432 16G Linux swap
/dev/sda10 1931483136 1953523271 22040136 10,5G Entorno de recuperación de Windows
You can see that windows is installed at /dev/sda4 (almost 500GB of data and OS)

Then I even added the following content at the /etc/grub.d/40_custom file
menuentry "windows 10" {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos4)'
search --no-floppy --fs-uuid --set=root 52F63E5BF63E3F91
chainloader +1
}

and then I run again grub2-mkconfig and it will never add your windows boot option at grub menu for creating the dual-boot

Houston !! we have a problem !
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-06-16 18:32 luiseb New Issue