View Issue Details

IDProjectCategoryView StatusLast Update
0017541CentOS-7ImageMagickpublic2020-06-28 01:51
Reporterguestales 
PrioritynormalSeveritymajorReproducibilityalways
Status confirmedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0017541: ImageMagick 6.9.10.68-3.el7 label not working
DescriptionFollowing the examples on https://imagemagick.org/Usage/text/#label it does not work as expected, it seems to ignore the -size ?
Steps To ReproduceFor the basic example:

convert -background lightblue -fill blue -font Courier-Bold -pointsize 72 label:Anthony label.gif

All I get is an image with a horizontal line. See uploaded files
Additional InformationI downgrated to ImageMagick-6.7.8.9-18.el7 and it works as the examples.

Centos 7
TagsNo tags attached.
abrt_hash
URL

Activities

guestales

guestales

2020-06-26 07:25

reporter  

label.gif (327 bytes)
label.gif (327 bytes)
guestales

guestales

2020-06-26 07:33

reporter   ~0037241

Also ignores the \n option (added -size 500x50)

convert -background lightblue -fill blue -font Courier-Bold -size 500x50 -pointsize 20 label:'ImageMagick\nRules - OK!' label_multiline.gif

label_multiline.gif (2,207 bytes)
label_multiline.gif (2,207 bytes)
ManuelWolfshant

ManuelWolfshant

2020-06-28 01:51

manager   ~0037251

Same thing seems to happen for me, with various fonts. Can you please file a bug at bugzilla.redhat.com and crosslink the two bugs together ? Since CentOS is built from the RHEL sources published by RedHat, the bug in CentOS cannot be fixed until it gets fixed in RHEL.

Issue History

Date Modified Username Field Change
2020-06-26 07:25 guestales New Issue
2020-06-26 07:25 guestales File Added: label.gif
2020-06-26 07:33 guestales File Added: label_multiline.gif
2020-06-26 07:33 guestales Note Added: 0037241
2020-06-28 01:51 ManuelWolfshant Status new => confirmed
2020-06-28 01:51 ManuelWolfshant Note Added: 0037251