View Issue Details

IDProjectCategoryView StatusLast Update
0017567CentOS CI[All Projects] generalpublic2020-07-10 06:20
Reporterjlebon 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0017567: Service account `jenkins` in project `coreos-ci` needs `anyuid` SCC
DescriptionPlease add the `jenkins` service account in the `coreos-ci` project to the `anyuid` SCC so that we can run tests as uid 0.

Thanks!
TagsNo tags attached.

Relationships

parent of 0017573 resolvedsiddharthvipul1 Need `CAP_SETFCAP` for service account `jenkins` in project `coreos-ci` 

Activities

jlebon

jlebon

2020-07-06 20:50

reporter   ~0037313

This should do the trick:

$ oc project coreos-ci
$ oc adm policy add-scc-to-user anyuid -z jenkins
jlebon

jlebon

2020-07-07 13:05

reporter   ~0037325

We need this because many of our tests need to be able to do e.g. `sudo make install` or `yum install $freshly_built_rpms`.

Issue History

Date Modified Username Field Change
2020-07-06 20:42 jlebon New Issue
2020-07-06 20:42 jlebon Status new => assigned
2020-07-06 20:50 jlebon Note Added: 0037313
2020-07-07 13:05 jlebon Note Added: 0037325
2020-07-09 05:01 siddharthvipul1 Relationship added parent of 0017573
2020-07-10 06:20 siddharthvipul1 Status assigned => resolved
2020-07-10 06:20 siddharthvipul1 Resolution open => fixed