View Issue Details

IDProjectCategoryView StatusLast Update
0017575CentOS-8anacondapublic2020-10-14 18:26
Reportermmarusak Assigned To 
Status newResolutionopen 
Product Version8.2.2004 
Summary0017575: New ISO images cannot be installed (with kickstart file?)
DescriptionIn Cockpit team we are using centos-8-stream isos to create our testing images. Recently isos were replaced with new ones but they fail to be installed by anaconda.
I don't think it is anaconda bug, but had no idea what to report against and since it fails in anaconda I thought it is a good enough starting point.
Steps To Reproduce```
$ wget -O centos-8-stream.iso
$ qemu-img create -f qcow2 /var/tmp/centos-8-stream-2.qcow2 12G
$ virt-install --connect=qemu:///session --initrd-inject=fedora.ks '--extra-args=ks=file:/fedora.ks console=ttyS0,115200' --name=centos-8-stream-2.qcow2-builder --disk path=/var/tmp/centos-8-stream-2.qcow2,format=qcow2 --ram 4096 --vcpus=1 --os-type linux --os-variant fedora21 --location=centos-8-stream.iso --nographics --noreboot
$ cat fedora.ks
lang en_US.UTF-8
keyboard us
network --bootproto dhcp
rootpw foobar
firewall --enabled --ssh
selinux --enforcing
timezone --utc America/New_York
bootloader --location=mbr --append="console=ttyS0,115200 rd_NO_PLYMOUTH"
clearpart --all --initlabel


mkdir /root/.ssh
chmod 700 /root/.ssh
echo "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDUOtNJdBEXyKxBB898rdT54ULjMGuO6v4jLXmRsdRhR5Id/lKNc9hsdioPWUePgYlqML2iSV72vKQoVhkyYkpcsjr3zvBny9+5xej3+TBLoEMAm2hmllKPmxYJDU8jQJ7wJuRrOVOnk0iSNF+FcY/yaQ0owSF02Nphx47j2KWc0IjGGlt4fl0fmHJuZBA2afN/4IYIIsEWZziDewVtaEjWV3InMRLllfdqGMllhFR+ed2hQz9PN2QcapmEvUR4UCy/mJXrke5htyFyHi8ECfyMMyYeHwbWLFQIve4CWix9qtksvKjcetnxT+WWrutdr3c9cfIj/c0v/Zg/c4zETxtp cockpit-test" > /root/.ssh/authorized_keys
chmod 600 /root/.ssh/authorized_keys
mkdir -p /etc/sysconfig/network-scripts
echo "BOOTPROTO="dhcp"
ONBOOT="yes"" > /etc/sysconfig/network-scripts/ifcfg-eth0
echo "BOOTPROTO="none"
ONBOOT="no"" > /etc/sysconfig/network-scripts/ifcfg-eth1
sed -i 's/GRUB_TIMEOUT.*/GRUB_TIMEOUT=0/; /GRUB_CMDLINE_LINUX=/ s/"$/ net.ifnames=0 biosdevname=0"/' /etc/default/grub
grub2-mkconfig -o /boot/grub2/grub.cfg
systemctl is-enabled sshd.socket || systemctl is-enabled sshd.service || systemctl enable sshd.socket
echo "" > /root/npm-registry


It is stuck at:

1) [x] Language settings 2) [x] Time settings
       (English (United States)) (America/New_York timezone)
3) [!] Installation source 4) [!] Software selection
       (Error setting up software (Error checking software
       source) selection)
5) [x] Installation Destination 6) [x] Kdump
       (Automatic partitioning (Kdump is enabled)
7) [x] Network configuration 8) [ ] User creation
       (Wired (ens2) connected) (No user will be created)

Please make a selection from the above ['b' to begin installation, 'q' to quit,
'r' to refresh]: b
Please complete all spokes before continuing

Steps 3 and 4 are not completed. It worked with previous [1] isos. It also works with other OSes we use, such as fedora, rhel... (although we don't use iso files, but the installation process is the same).

Additional InformationWhen I took the ISO and just ran it with gnome boxes it installed correctly. It seems that the problem might be related to using kickstart and unattended installation?
TagsNo tags attached.




2020-07-29 20:43

reporter   ~0037447

Happens with me, too. Drove me nuts yesterday. I can install manually with the CentOS-8.2.2004-dvd1.iso, but not with kickstart. It's like anaconda isn't finding the kickstart file. With CentOS 8.1 and earlier, it did just fine.

In my case, I'm using packer to build VMs in vSphere, and I can get onto the VM's consoles while packer is booting them up. I can see them go to the graphical installer and just sit. If I interceded and tab to add the inst.text kernel command line option, it'll start the text installer, but it's clear from the settings in that screen that it hasn't seen the kickstart file.

I'd be happy to do any troubleshooting you like.


2020-07-30 15:33

reporter   ~0037451

A collegue reminded me about labeling the ISO Volume as OEMDEV and once I did that, The 8.2 anaconda is now reading my kickstart file and it all works now.

"mkisofs -V OEMDEV -o kickstart8.iso ./ks.cfg " produced an ISO with the ks.cfg in it that anaconda find.


2020-08-04 07:52

reporter   ~0037484

Hey Mike,
glad to hear that you were able to resolve it. However I am not sure if I understand your solution. Could you please elaborate a bit more?

`mkisofs -V OEMDEV -o kickstart8.iso ./ks.cfg`
What is the content of `ks.cfg`? Does the official iso file come into play somehow?


2020-08-06 08:04

reporter   ~0037504

@Mike: So you inject the kickstart through an iso file? We just use virt-install's documented way through `--initrd-inject` to get the file into the installer env, and `--extra-args="ks=file://path/to/ks`. This has worked for years, and still works fine for anything except the very latest CentOS 8 stream, so it's definitively a regression.

virt-install doesn't seem to have a straightforward way to boot with two ISOs. Do you use `--disks` multiple times?


2020-08-10 15:42

reporter   ~0037515

We're using Packer to create VMs as templates in VMware. As far as I can tell, it's simply attaching two DVD/CD-ROM drives. The first has the first ISO I list, the second has the second ISO I list, which has the ks.cfg file in it's root.


2020-09-16 15:52

reporter   ~0037704

This seems fixed on CentOS-Stream-8-x86_64-20200910-dvd1.iso , so please close. Thanks!


2020-10-07 08:36

reporter   ~0037791

Centos Minimal 8.2 installation breaks. I am using Fusion 12, but error messages seem to come from Anaconda/kickstart.

ISSUES: CentOS-8.2.2004-x86_64-minimal.iso 2020-06-08 22:09 1.6G can not be installed.

1. Message (see attached print screen)
Problems in request...
1.1 Click "no" -> terminate message on the screen and the system boots. (=ISSUE #1)
1.2 Yes -> installation continues
2. Message (see attached print screen)
An unknown error has occurred... (=ISSUE "2)


2020-10-07 08:39

reporter   ~0037792

Right second print screen


2020-10-07 08:42

reporter   ~0037793

The debugger shows in the minimal 8.2 that it is that raises the error:


2020-10-14 18:26

reporter   ~0037811

Installation of ISO files on the VMware Fusion 12.0.0 (The newest updated version)

Installation ISO-file Date time Size
NOT OK CentOS-8.2.2004-x86_64-minimal.iso 08-Jun-2020 22:09 1718616064
OK CentOS-8.2.2004-x86_64-dvd1.iso 08-Jun-2020 22:11 8231321600

Issue History

Date Modified Username Field Change
2020-07-08 05:41 mmarusak New Issue
2020-07-29 20:43 MikeDiehn Note Added: 0037447
2020-07-30 15:33 MikeDiehn Note Added: 0037451
2020-08-04 07:52 mmarusak Note Added: 0037484
2020-08-06 08:04 Martin.Pitt Note Added: 0037504
2020-08-10 15:42 MikeDiehn Note Added: 0037515
2020-09-16 15:52 Martin.Pitt Note Added: 0037704
2020-10-07 08:36 harri File Added: Näyttökuva 2020-10-7 kello 10.22.35.png
2020-10-07 08:36 harri File Added: Näyttökuva 2020-10-7 kello 10.22.35-2.png
2020-10-07 08:36 harri Note Added: 0037791
2020-10-07 08:39 harri File Added: Näyttökuva 2020-10-7 kello 10.46.18.png
2020-10-07 08:39 harri Note Added: 0037792
2020-10-07 08:42 harri File Added: Näyttökuva 2020-10-7 kello 11.40.58.png
2020-10-07 08:42 harri Note Added: 0037793
2020-10-14 18:26 harri Note Added: 0037811