View Issue Details

IDProjectCategoryView StatusLast Update
0017583CentOS-8phppublic2020-09-18 16:42
ReporterCHW 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version8.2.2004 
Target VersionFixed in Version8.2.2004 
Summary0017583: php 7.3 stream: php-pecl-apcu and php-pecl-zip missing
DescriptionI've just tried installing those on a fresh install and get the following error:

All matches were filtered out by modular filtering for argument: php-pecl-apcu
All matches were filtered out by modular filtering for argument: php-pecl-zip
Error: Unable to find a match: php-pecl-apcu php-pecl-zip

The modules in the repos are on version el8.2.0+313+b04d0a66, while php 7.3 is on version el8.2.0+314+53b99e08.

I've also checked on an older install that has recently been upgraded from CentOS 8.1 to 8.2 and the version on there is still el8.1.0+252+0d4e049c.
Steps To Reproducednf module enable -y php:7.3
dnf install -y php-pecl-apcu php-pecl-zip
Tagsmodule-stream, php

Relationships

has duplicate 0017615 newbstinson Missing packages in Module Stream PHP 7.3 

Activities

tru

tru

2020-07-23 16:21

administrator   ~0037408

confirmed:
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/php-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/php-7.3.5-5.module_el8.2.0+314+53b99e08.x86_64.rpm

/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/libzip-1.5.1-2.module_el8.2.0+313+b04d0a66.x86_64.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/libzip-devel-1.5.1-2.module_el8.2.0+313+b04d0a66.x86_64.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/libzip-tools-1.5.1-2.module_el8.2.0+313+b04d0a66.x86_64.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/php-pecl-zip-1.15.3-1.module_el8.2.0+313+b04d0a66.x86_64.rpm
VS
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/libzip-1.5.2-1.module_el8.2.0+314+53b99e08.x86_64.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/libzip-devel-1.5.2-1.module_el8.2.0+314+53b99e08.x86_64.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/libzip-tools-1.5.2-1.module_el8.2.0+314+53b99e08.x86_64.rpm

and
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/apcu-panel-5.1.12-2.module_el8.2.0+313+b04d0a66.noarch.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/php-pecl-apcu-5.1.12-2.module_el8.2.0+313+b04d0a66.x86_64.rpm
/var/ftp/pub/centos/8.2.2004/AppStream/x86_64/os/Packages/php-pecl-apcu-devel-5.1.12-2.module_el8.2.0+313+b04d0a66.x86_64.rpm
VS
<nada> for *apcu*module_el8.2.0+313+b04d0a66*
ngompa

ngompa

2020-07-25 19:18

reporter   ~0037416

This is impacting me as well.

At least based on the php:7.3 module definition[1] (compared to the php:7.2 one[2]), I expect these packages to be present in the repositories...

[1]: https://git.centos.org/modules/php/blob/c8-stream-7.3/f/php.yaml
[2]: https://git.centos.org/modules/php/blob/c8-stream-7.2/f/php.yaml
ngompa

ngompa

2020-07-25 19:21

reporter   ~0037417

I can also confirm that these packages are *supposed* to exist in the php:7.3 module since they remain present on my RHEL 8.2 machine and my UBI 8 container (which is based on RHEL 8.2 content).
ngompa

ngompa

2020-07-27 17:08

reporter   ~0037421

As this problem also exists in CentOS Stream, I've filed a bug report for that too: https://bugzilla.redhat.com/show_bug.cgi?id=1861050
flotho

flotho

2020-07-28 16:35

reporter   ~0037430

Hi,

I have the same issue on a fresh COS8 installed.
what is surprising is that it has been working and it's also available here : https://centos.pkgs.org/8/centos-appstream-x86_64/php-pecl-apcu-5.1.12-2.module_el8.2.0+313+b04d0a66.x86_64.rpm.html offically in appstream.

Regards
remi

remi

2020-07-29 05:57

reporter   ~0037439

@flotho, apcu-5.1.12 is in the 7.2 stream, missing in the 7.3

More information (full expected content, from RHEL) in #17615

4 packages are missing in 7.3 stream

- php-pecl-zip
- php-pecl-apcu
- php-pecl-xdebug
- php-pecl-rrd
flotho

flotho

2020-07-29 15:55

reporter   ~0037445

Hi remi,

Thanks, hopefully I can use your repos ;-)

Regards
CHW

CHW

2020-08-11 11:28

reporter   ~0037520

According to koji.mbox.centos.org everything was build, it's just not in the repos.
php-pecl-zip https://koji.mbox.centos.org/koji/buildinfo?buildID=7726
php-pecl-apcu https://koji.mbox.centos.org/koji/buildinfo?buildID=7728
php-pecl-xdebug https://koji.mbox.centos.org/koji/buildinfo?buildID=7727
php-pecl-rrd https://koji.mbox.centos.org/koji/buildinfo?buildID=7725

So, the fix, to me, seems trivial: just copy those packages to the mirrors and done, no?
carlwgeorge

carlwgeorge

2020-09-18 16:22

developer   ~0037709

This was resolved with php-7.3-8020020200826164332.2c7ca891.

https://koji.mbox.centos.org/koji/buildinfo?buildID=13235

Issue History

Date Modified Username Field Change
2020-07-09 14:57 CHW New Issue
2020-07-23 16:21 tru Note Added: 0037408
2020-07-25 19:18 ngompa Note Added: 0037416
2020-07-25 19:21 ngompa Note Added: 0037417
2020-07-25 23:12 toracat Relationship added has duplicate 0017615
2020-07-27 17:08 ngompa Note Added: 0037421
2020-07-28 16:35 flotho Note Added: 0037430
2020-07-29 05:57 remi Note Added: 0037439
2020-07-29 15:55 flotho Note Added: 0037445
2020-08-11 11:28 CHW Note Added: 0037520
2020-08-26 00:11 cmpalmer Tag Attached: php
2020-08-26 00:11 cmpalmer Tag Attached: module-stream
2020-09-18 16:22 carlwgeorge Note Added: 0037709
2020-09-18 16:42 carlwgeorge Status new => closed
2020-09-18 16:42 carlwgeorge Resolution open => fixed
2020-09-18 16:42 carlwgeorge Fixed in Version => 8.2.2004