View Issue Details

IDProjectCategoryView StatusLast Update
0017599CentOS-8awsclipublic2020-07-17 22:50
Reporterkevbo Assigned To 
Status newResolutionopen 
Product Version8.2.2004 
Summary0017599: AWSCLI on Centos 8: RPM installation non-functional
DescriptionThere does not seem to be any "normal" way to install the awscli package (Amazon AWS CLI) on CentOS 8.

The package itself exists in CentosHA, and if you enable that repo and then dnf install awscli:

 awscli noarch 1.14.50-5.el8 HighAvailability 1.1 M
 python3-botocore noarch 1.9.1-2.el8 HighAvailability 2.8 M

it installs an older botocore from what's currently in the main product, and a fairly old version of awscli (but that's not my primary concern).

The issue is, this then doesn't work:

[kwhite@bind ~]$ /usr/bin/aws
Traceback (most recent call last):
  File "/usr/bin/aws", line 27, in <module>
  File "/usr/bin/aws", line 23, in main
    return awscli.clidriver.main()
  File "/usr/lib/python3.6/site-packages/awscli/", line 58, in main
    driver = create_clidriver()
  File "/usr/lib/python3.6/site-packages/awscli/", line 69, in create_clidriver
  File "/usr/lib/python3.6/site-packages/awscli/", line 44, in load_plugins
    modules = _import_plugins(plugin_mapping)
  File "/usr/lib/python3.6/site-packages/awscli/", line 61, in _import_plugins
    module = __import__(path, fromlist=[module])
  File "/usr/lib/python3.6/site-packages/awscli/", line 27, in <module>
    from awscli.customizations.cloudformation import initialize as cloudformation_init
  File "/usr/lib/python3.6/site-packages/awscli/customizations/cloudformation/", line 13, in <module>
    from awscli.customizations.cloudformation.package import PackageCommand
  File "/usr/lib/python3.6/site-packages/awscli/customizations/cloudformation/", line 26, in <module>
    from awscli.customizations.s3uploader import S3Uploader
  File "/usr/lib/python3.6/site-packages/awscli/customizations/", line 22, in <module>
    from s3transfer.manager import TransferManager
  File "/usr/lib/python3.6/site-packages/s3transfer/", line 21, in <module>
    from s3transfer.utils import get_callbacks
  File "/usr/lib/python3.6/site-packages/s3transfer/", line 27, in <module>
    from botocore.exceptions import ReadTimeoutError
ImportError: cannot import name 'ReadTimeoutError'

I've tried it with an actual command (like /usr/bin/aws s3 ls) and get the same result.
Steps To Reproducesudo dnf config-manager --set-enabled HighAvailability
sudo dnf install awscli
TagsNo tags attached.


There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-07-17 22:50 kevbo New Issue