View Issue Details

IDProjectCategoryView StatusLast Update
0017617CentOS-8xorg-x11-proto-develpublic2020-07-24 07:47
Reporterjenningsloy318 
PriorityhighSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version8.2.2004 
Target VersionFixed in Version 
Summary0017617: xorg-x11-proto-devel version 2020.1-2.el8 missing /usr/include/X11/extensions/XKBgeom.h
Descriptionversion 2020.1-2.el8 of xorg-x11-proto-devel didn't contain /usr/include/X11/extensions/XKBgeom.h, but the previous 2019.1 or 2018.4 contains the file. a parameter --enable-legacy --with-legacy-headers should be added when building package xorg-x11-proto


Additional Informationas libX11-devel upgraded to 1.6.9 (in fedora) contains /usr/include/X11/extensions/XKBgeom.h, but Centos 8 only build libX11-devel 1.6.8 which don't contains this file.

so the solution is that either we upgrade to libX11-devel 1.6.9 which contains /usr/include/X11/extensions/XKBgeom.h or re-build xorg-x11-proto-devel version 2020.1 to add --enable-legacy --with-legacy-headers to make xorg-x11-proto include /usr/include/X11/extensions/XKBgeom.h.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-07-24 07:47 jenningsloy318 New Issue