View Issue Details

IDProjectCategoryView StatusLast Update
0017627CentOS-7kernelpublic2020-07-29 08:10
Reporterxky 
PriorityurgentSeveritycrashReproducibilityrandom
Status closedResolutionno change required 
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0017627: Corruption of in-memory data detected, Shutting down filesystem
DescriptionThis problem occured once when the power is turned on again after a sudden power failure. The reboot operation occurred twice, it's just an occasional problem. I don't know what the trigger condition is. The Internet says that this problem can be fixed with xfs_repair, but it doesn't make much sense.
Steps To ReproduceStart after sudden power failure or reboot
Additional Information#uname -mrs
Linux 3.10.0-693.el7.x86_64 x86_64
TagsNo tags attached.
abrt_hash
URL

Activities

xky

xky

2020-07-29 06:47

reporter  

1.jpg (240,426 bytes)
1.jpg (240,426 bytes)
2.PNG (1,821,660 bytes)
ManuelWolfshant

ManuelWolfshant

2020-07-29 07:06

manager   ~0037440

Since almost forever the OS keeps in memory various data related to the filesystems and minimizes writes back to the physical layer. This is well documented all over the place and is one of the reasons sudden power failures are always a risk and that's why hardware RAID controllers have an internal battery backup and why UPSes have been invented.
Please use a proper venue for support requests ( like IRC / fora / mailing list ) if you need one, not the bug tracker.
TrevorH

TrevorH

2020-07-29 08:08

manager   ~0037441

Also, 7.4 is 3 whole years out of date and there are *602* entries in the latest kernel (3.10.0-1127.13.1.el7.x86_64) rpm changelog that mention xfs in them.

yum update

Issue History

Date Modified Username Field Change
2020-07-29 06:47 xky New Issue
2020-07-29 06:47 xky File Added: 1.jpg
2020-07-29 06:47 xky File Added: 2.PNG
2020-07-29 07:06 ManuelWolfshant Status new => closed
2020-07-29 07:06 ManuelWolfshant Resolution open => no change required
2020-07-29 07:06 ManuelWolfshant Note Added: 0037440
2020-07-29 08:08 TrevorH Note Added: 0037441