View Issue Details

IDProjectCategoryView StatusLast Update
0017634CentOS-8-OTHERpublic2021-07-13 17:31
Reporterlukemewburn Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version8.2.2004 
Summary0017634: Judy-devel rpm missing in 8.2, is present in 8.1
DescriptionThe package "Judy-devel" is missing in CentOS 8.2 even though is present in CentOS 8.1.
The non-devel "Judy" is present in both 8.1 and 8.2.
Judy-devel appears to be present in upstream 8.2 too.

This problem has been noted in various external projects including: https://github.com/netdata/netdata/issues/9356
Steps To Reproduce"yum install Judy-devel" on a fresh 8.2 system.
Additional InformationThe package "Judy" in 8.1 appears to be the same as 8.2:
- http://vault.centos.org/8.1.1911/AppStream/x86_64/os/Packages/Judy-1.0.5-18.module_el8.1.0+217+4d875839.x86_64.rpm
- http://mirror.centos.org/centos/8/AppStream/x86_64/os/Packages/Judy-1.0.5-18.module_el8.1.0+217+4d875839.x86_64.rpm

The 8.1 version of Judy-devel is in PowerTools not AppStream:
- http://vault.centos.org/8.1.1911/PowerTools/x86_64/os/Packages/Judy-devel-1.0.5-18.module_el8.1.0+217+4d875839.x86_64.rpm
TagsNo tags attached.

Activities

lukemewburn

lukemewburn

2021-07-12 04:25

reporter   ~0038532

This issue can be closed.

As of CentOS 8.3 (and CentOS 8.4), the Judy-devel package is now part of PowerTools again, and can be installed if the "PowerTools" repo is enabled and the "mariadb-devel" module is enabled.
$ dnf config-manager --set-enabled PowerTools
$ dnf module enable mariadb-devel
$ dnf install Judy-devel

Issue History

Date Modified Username Field Change
2020-07-31 02:28 lukemewburn New Issue
2020-07-31 12:05 jerryneillstill Issue cloned: 0017636
2021-07-12 04:25 lukemewburn Note Added: 0038532
2021-07-13 17:31 toracat Status new => resolved
2021-07-13 17:31 toracat Resolution open => no change required