View Issue Details

IDProjectCategoryView StatusLast Update
0017649CentOS-8kernelpublic2020-08-07 15:44
Reporternipunasri.eerapu@gmail.com 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0017649: kernel fails to boot as AWS PV guest
DescriptionWhen booting a CentOS 8 as an AWS paravirtual guest with kernel 4.18.0-80.11.2.el8_0.x86_64, the kernel fails to boot with the following output on the console log:

Tpmfront:Error Unable to read device/vtpm/0/backend-id during tpmfront initialization! error = ENOENT
Tpmfront:Info Shutting down tpmfront
xc: error: elf_xen_addr_calc_check: ERROR: ELF start or entries are out of bounds.: Invalid kernel
xc_dom_parse_image returned -1
close(3)

Error 9: Unknown boot failure

Press any key to continue...
Steps To ReproduceCreate a CentOS 8 image an boot it in AWS as a paravirtual guest.
Additional InformationThe full console log is below:

Xen Minimal OS!
  start_info: 0x10d4000(VA)
    nr_pages: 0xe504a
  shared_inf: 0xeeb28000(MA)
     pt_base: 0x10d7000(VA)
nr_pt_frames: 0xd
    mfn_list: 0x9ab000(VA)
   mod_start: 0x0(VA)
     mod_len: 0
       flags: 0x300
    cmd_line: root=/dev/sda1 ro console=hvc0 4
  stack: 0x96a100-0x98a100
MM: Init
      _text: 0x0(VA)
     _etext: 0x7b824(VA)
   _erodata: 0x97000(VA)
     _edata: 0x9cce0(VA)
stack start: 0x96a100(VA)
       _end: 0x9aa700(VA)
  start_pfn: 10e7
    max_pfn: e504a
Mapping memory range 0x1400000 - 0xe504a000
setting 0x0-0x97000 readonly
skipped 0x1000
MM: Initialise page allocator for 1809000(1809000)-e504a000(e504a000)
MM: done
Demand map pfns at e504b000-20e504b000.
Heap resides at 20e504c000-40e504c000.
Initialising timer interface
Initialising console ... done.
gnttab_table mapped at 0xe504b000.
Initialising scheduler
Thread "Idle": pointer: 0x20e504c050, stack: 0x1f10000
Thread "xenstore": pointer: 0x20e504c800, stack: 0x1f20000
xenbus initialised on irq 3 mfn 0xfeffc
Thread "shutdown": pointer: 0x20e504cfb0, stack: 0x1f30000
Dummy main: start_info=0x98a200
Thread "main": pointer: 0x20e504d760, stack: 0x1f40000
"main" "root=/dev/sda1" "ro" "console=hvc0" "4"
vbd 2049 is hd0

******************* BLKFRONT for device/vbd/2049 **********

backend at /local/domain/0/backend/vbd/23122/2049
4194304 sectors of 512 bytes
**************************
vbd 2064 is hd1
******************* BLKFRONT for device/vbd/2064 **********

backend at /local/domain/0/backend/vbd/23122/2064
8377344 sectors of 512 bytes

**************************

[H[J Booting 'CentOS Linux (4.18.0-80.11.2.el8_0.x86_64) 8 (Core)'
root (hd0)
 Filesystem type is ext2fs, using whole disk
kernel /boot/vmlinuz-4.18.0-80.11.2.el8_0.x86_64 ro root=UUID=59e5916a-b1ee-4bb
e-b334-3c5b7935aaa5 consoleblank=0 console=hvc0 net.ifnames=0
initrd /boot/initramfs-4.18.0-80.11.2.el8_0.x86_64.img

============= Init TPM Front ================

Tpmfront:Error Unable to read device/vtpm/0/backend-id during tpmfront initialization! error = ENOENT
Tpmfront:Info Shutting down tpmfront
xc: error: elf_xen_addr_calc_check: ERROR: ELF start or entries are out of bounds.: Invalid kernel
xc_dom_parse_image returned -1
close(3)

Error 9: Unknown boot failure

Press any key to continue...
TagsNo tags attached.

Relationships

duplicate of 0016881 new kernel fails to boot as AWS PV guest 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-08-07 06:51 nipunasri.eerapu@gmail.com New Issue
2020-08-07 06:51 nipunasri.eerapu@gmail.com Issue generated from: 0016881
2020-08-07 06:51 nipunasri.eerapu@gmail.com Relationship added duplicate of 0016881
2020-08-07 15:44 toracat Status new => closed
2020-08-07 15:44 toracat Resolution open => duplicate