View Issue Details

IDProjectCategoryView StatusLast Update
0017731CentOS CI[All Projects] generalpublic2020-09-22 07:07
ReporterMartin.Pitt 
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionopen 
Summary0017731: CentOS-Stream-8-x86_64-20200910-dvd1.iso uninstallable: gnutls/crypto-policies dependency problems
DescriptionRunning the current CentOS 8 Stream DVD through virt-install fails to install GnuTLS/libvirt:

+ yum --setopt=skip_missing_names_on_install=False -y install valgrind gdb strace ltrace nmap-ncat targetcli dnf-utils virt-install libvirt-daemon-config-network c
ryptsetup qemu-kvm socat vdo kmod-kvdo dracut-fips clevis-luks tang boom-boot glibc-all-langpacks dnf-automatic libvirt-daemon-config-network nodejs device-mapper-
multipath glib-networking json-glib kexec-tools libssh libvirt-dbus libvirt-client libvirt-daemon-kvm NetworkManager-team openssl PackageKit pcp-libs pcp realmd re
dhat-logos selinux-policy-targeted setroubleshoot-server subscription-manager sos tuned udisks2 udisks2-lvm2 udisks2-iscsi podman ipa-client oddjob oddjob-mkhomedi
r sssd sssd-dbus
Main config did not have a skip_missing_names_on_install attr. before setopt
Main config did not have a skip_missing_names_on_install attr. before setopt
Last metadata expiration check: 0:00:11 ago on Wed Sep 16 11:15:43 2020.
Package dracut-049-95.git20200804.el8.x86_64 is already installed.
Package kexec-tools-2.0.20-34.el8.x86_64 is already installed.
Package libssh-0.9.4-2.el8.x86_64 is already installed.
Package NetworkManager-team-1:1.26.0-7.el8.x86_64 is already installed.
Package openssl-1:1.1.1g-11.el8.x86_64 is already installed.
Package selinux-policy-targeted-3.14.3-53.el8.noarch is already installed.
Package tuned-2.14.0-3.el8.noarch is already installed.
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best c
andidate packages)
Error:
 Problem: package gnutls-utils-3.6.8-11.el8_2.x86_64 requires gnutls(x86-64) = 3.6.8-11.el8_2, but none of the providers can be installed
  - package crypto-policies-20200713-1.git51d1222.el8.noarch conflicts with gnutls < 3.6.12 provided by gnutls-3.6.8-11.el8_2.x86_64
  - package libvirt-client-4.5.0-42.module_el8.2.0+320+13f867d7.x86_64 requires gnutls-utils, but none of the providers can be installed
  - package crypto-policies-scripts-20200713-1.git51d1222.el8.noarch requires crypto-policies = 20200713-1.git51d1222.el8, but none of the providers can be install
ed
  - conflicting requests
  - problem with installed package crypto-policies-scripts-20200713-1.git51d1222.el8.noarch
TagsNo tags attached.

Activities

Martin.Pitt

Martin.Pitt

2020-09-16 15:34

reporter   ~0037701

`yum install gnutls-utils` is enough to reproduce this.

gnutls-3.6.14-6.el8.x86_64 is installed, but that wants to install gnutls-utils-3.6.8-11.el8_2.x86_64. So it seems the install DVD was built with newer repositories than what /etc/yum.repos.d/CentOS-Base.repo gets?
Martin.Pitt

Martin.Pitt

2020-09-16 15:36

reporter   ~0037702

[root@m1 ~]# yum info gnutls
Last metadata expiration check: 0:00:05 ago on Wed Sep 16 11:35:32 2020.
Installed Packages
Name : gnutls
Version : 3.6.14
Release : 6.el8
Architecture : x86_64
Size : 2.8 M
Source : gnutls-3.6.14-6.el8.src.rpm
Repository : @System
From repo : anaconda
Summary : A TLS protocol implementation
URL : http://www.gnutls.org/
License : GPLv3+ and LGPLv2+
Description : GnuTLS is a secure communications library implementing the SSL, TLS and DTLS
             : protocols and technologies around them. It provides a simple C language
             : application programming interface (API) to access the secure communications
             : protocols as well as APIs to parse and write X.509, PKCS #12, OpenPGP and
             : other required structures.

Available Packages
Name : gnutls
Version : 3.6.8
Release : 11.el8_2
Architecture : i686
Size : 939 k
Source : gnutls-3.6.8-11.el8_2.src.rpm
Repository : BaseOS
Summary : A TLS protocol implementation
URL : http://www.gnutls.org/
License : GPLv3+ and LGPLv2+
Description : GnuTLS is a secure communications library implementing the SSL, TLS and DTLS
             : protocols and technologies around them. It provides a simple C language
             : application programming interface (API) to access the secure communications
             : protocols as well as APIs to parse and write X.509, PKCS #12, OpenPGP and
             : other required structures.

[root@m1 ~]# yum repolist
repo id repo name
AppStream CentOS-8 - AppStream
BaseOS CentOS-8 - Base
extras CentOS-8 - Extras
Martin.Pitt

Martin.Pitt

2020-09-16 15:39

reporter   ~0037703

What seems to work is to apply a bigger hammer, which removes crypto-policies-scripts:

# yum install libvirt-client --allowerasing
Last metadata expiration check: 0:02:57 ago on Wed Sep 16 11:35:32 2020.
Dependencies resolved.
===================================================================================================================================================================
 Package Architecture Version Repository Size
===================================================================================================================================================================
Installing:
 libvirt-client x86_64 4.5.0-42.module_el8.2.0+320+13f867d7 AppStream 351 k
Installing dependencies:
 autogen-libopts x86_64 5.18.12-7.el8 AppStream 75 k
 avahi-libs x86_64 0.7-19.el8 BaseOS 62 k
 cyrus-sasl x86_64 2.1.27-1.el8 BaseOS 96 k
 cyrus-sasl-gssapi x86_64 2.1.27-1.el8 BaseOS 49 k
 gnutls-dane x86_64 3.6.8-11.el8_2 AppStream 45 k
 gnutls-utils x86_64 3.6.8-11.el8_2 AppStream 339 k
 libvirt-bash-completion x86_64 4.5.0-42.module_el8.2.0+320+13f867d7 AppStream 51 k
 libvirt-libs x86_64 4.5.0-42.module_el8.2.0+320+13f867d7 AppStream 4.1 M
 nmap-ncat x86_64 2:7.70-5.el8 AppStream 237 k
 yajl x86_64 2.1.0-10.el8 AppStream 41 k
Removing dependent packages:
 crypto-policies-scripts noarch 20200713-1.git51d1222.el8 @anaconda 125 k
Downgrading:
 crypto-policies noarch 20191128-2.git23e1bf1.el8 BaseOS 103 k
 cyrus-sasl-lib x86_64 2.1.27-1.el8 BaseOS 123 k
 gnutls x86_64 3.6.8-11.el8_2 BaseOS 915 k
Martin.Pitt

Martin.Pitt

2020-09-22 07:07

reporter   ~0037722

See also https://bugzilla.redhat.com/show_bug.cgi?id=1879851 which is a similar confusion/mixup of "stream" vs. "regular" yum repositories. The DVD seems to configure the wrong yum repos, which most likely also results in this problem.

Issue History

Date Modified Username Field Change
2020-09-16 15:30 Martin.Pitt New Issue
2020-09-16 15:30 Martin.Pitt Status new => assigned
2020-09-16 15:34 Martin.Pitt Note Added: 0037701
2020-09-16 15:36 Martin.Pitt Note Added: 0037702
2020-09-16 15:39 Martin.Pitt Note Added: 0037703
2020-09-22 07:07 Martin.Pitt Note Added: 0037722