View Issue Details

IDProjectCategoryView StatusLast Update
0017747CentOS-8systemdpublic2021-07-05 14:38
Reportergreg.hellings Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0017747: CentOS systemd on newer kernels fails
DescriptionWhen running systemd from CentOS 8 on a newer kernel, the behavior is affected by the bug addressed upstream in this patch: https://github.com/systemd/systemd/pull/16420/files

This becomes an issue when running a CentOS 8 container image on a newer host, for instance on a Fedora host. Applying the above patch should allow the systemd in CentOS 8 to fail in an appropriate manner rather than producing error messages.
Steps To Reproduce1. Create a host running a 5.8 or later kernel
2. podman run --name c8 -d centos:8 /sbin/init
3. podman exec -it c8 /bin/bash
4. systemctl show sshd

At the top of the output of the systemctl show command will be the error message:
Failed to parse bus message: Invalid argument

Additionally, information like the state of the service will be missing from the output. The above patch is supposed to allow this command to fail gracefully and the known information to be reported back to the user.
TagsNo tags attached.

Activities

timj

timj

2020-12-16 13:31

reporter   ~0038090

I see this with a fully updated CentOS 8 Streams VM and the following:
kernel-4.18.0-257.el8.x86_64
systemd-239-43.el8.x86_64

It prevents any Ansible job that tries to manage a systemd service running properly (failing with "Service is in unknown state", as described in https://github.com/ansible/ansible/issues/71528 ).

Rolling the kernel back to 4.18.0-257.el8.x86_64 successfully works around it.
timj

timj

2020-12-17 12:34

reporter   ~0038097

https://bugzilla.redhat.com/show_bug.cgi?id=1908275
toracat

toracat

2021-01-05 22:43

manager   ~0038159

Last edited: 2021-01-05 23:12

RHBZ 1908275 was closed as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1901449 .

toracat

toracat

2021-04-17 17:42

manager   ~0038388

Fixed upstream.

Issue History

Date Modified Username Field Change
2020-09-22 04:53 greg.hellings New Issue
2020-12-16 13:31 timj Note Added: 0038090
2020-12-17 12:34 timj Note Added: 0038097
2021-01-05 22:43 toracat Note Added: 0038159
2021-01-05 22:44 toracat Status new => acknowledged
2021-01-05 23:12 toracat Note Edited: 0038159
2021-04-17 17:42 toracat Status acknowledged => resolved
2021-04-17 17:42 toracat Resolution open => fixed
2021-04-17 17:42 toracat Note Added: 0038388