View Issue Details

IDProjectCategoryView StatusLast Update
0001776CentOS-5kernelpublic2007-11-27 12:54
Reportertoracat 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 - i386 Beta 
Target VersionFixed in Version5.1 
Summary0001776: kernel panic because of a bug in the cifs module
DescriptionMounting a remote Windows share causes kernel panic/oops. This is a known bug in cifs 1.45 and the patch was made available in January by samba programmers. The details of this bug can be found in RedHat bugzilla.

 For example,
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211672
 or
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=214622

The patch appeared here:

http://www.kernel.org/git/?p=linux/kernel/git/sfrench/cifs-2.6.git;a=commitdiff;h=8e6f195af0e1f226e9b2e0256af8df46adb9d595

This bug will appear in RHEL5 because the fix came out too late to be included.

While the bug does not affect everyone, it is serious enough for users who cifs-mount Windows shares. Until the issue was resolved, those of us that were affected simply could not move on to kernel >= 2.6.18.
Additional InformationI am hoping that the patch gets included in CentOSplus (KB declared that the chances for including a patch like that in the distro kernel are absolutely zero). RHEL 5.1 will have this fix in as per Steve Dickson of RedHat.
TagsNo tags attached.

Relationships

has duplicate 0002194 closed CentOS-5 crash after mount to XP shared folder 
related to 0001062 closed CentOS-4 smbmount not working properly - smb_retry: no connection process 

Activities

GregSwallow

GregSwallow

2007-03-14 01:26

updater   ~0004564

Might be fixed in the kernel here:
http://people.redhat.com/linville/kernels/rhel5/
JohnnyHughes

JohnnyHughes

2007-03-14 03:04

administrator   ~0004565

maybe we can do a centosplus kernel after the final release if it is not fixed in 5.0 release
toracat

toracat

2007-03-15 17:41

manager   ~0004580

Just downloaded this kernel source:

http://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/kernel-2.6.18-8.1.1.el5.src.rpm

The kernel-2.6.spec file is dated 2/26/2007. If this is the kernel that is used in the final release of RHEL5, then the cifs bug fix is not there. Sigh.

Akemi
toracat

toracat

2007-03-15 17:52

manager   ~0004581

Forgot to mention that the kernel in
http://people.redhat.com/linville/kernels/rhel5/
had the same version of cifs (1.45).

As Steve Dickson of RedHat stated, the patch for this bug apparently did not make it into RHEL5.

Akemi
Charlie Brady

Charlie Brady

2007-03-20 21:44

reporter   ~0004630

> maybe we can do a centosplus kernel after the final release if it is not
> fixed in 5.0 release

I would suggest that instead you do a kmod-cifs RPM, with module installed under /lib/modules/2.6.18-1.2747.el5PAE/updates/.
toracat

toracat

2007-04-12 16:43

manager   ~0004783

Installed 5.0 and updated the kernel to the version available as of April 12, 2007 (2.6.18-8.1.1.el5). I confirmed this bug still exists.

Akemi
toracat

toracat

2007-04-14 10:00

manager   ~0004790

I compiled the cifs module after applying the patch and confirmed that the problem was fixed. I am attempting to upload cifs.ko (kernel 2.6.18-8.1.1.el5, arch i386) for anyone who is interested in this fix.

Akemi
JohnnyHughes

JohnnyHughes

2007-04-17 18:12

administrator   ~0004823

Last edited: 2007-04-17 18:14

OK ... working with toracat, I have created cifs.ko modules that can be used until this problem is fixed (they need testing).

The files can downloaded here:
http://centos.hughesjr.com/testing/smb_patch/

These are in smb_term_problem.i386.tar.bz2:
i686/cifs.ko
i686PAE/cifs.ko
i686PAEplus/cifs.ko
i686plus/cifs.ko
i686xen/cifs.ko
i686xenplus/cifs.ko

There are is smb_term_problem.x86_64.tar.bz2:
x86_64/cifs.ko
x86_64plus/cifs.ko
x86_64xen/cifs.ko
x86_64xenplus/cifs.ko

You can copy the proper cifs.ko to "/lib/modules/$KERNEL_VER/updates/" then run the command:

depmod -a

( substitute the proper vernel version for $KERNEL_VER )

Then this command should load the new module:

modprobe cifs

Please test and let us know if this fixes the problem and many thanks to toracat for find this bug and helping trobleshot it with us and upstream.

toracat

toracat

2007-04-17 18:53

manager   ~0004824

I have just done the first test and the result was A-OK. The bug is gone. I only tested the i386 version. I have yet to set up a x86_64 system. But I would be surprised if the x86_64 version does not work.

In the meantime, if there is anyone who is willing to test the patch, it is really easy. You do not have to wait for the system to crash. Just cifs-mount some Windows share and:

cat /proc/fs/cifs/DebugData

If the bug exists, you will see garbled characters in the output.

Thanks, Johnny, for taking the time and fixing the problem. I will continue with the test and report back with anything I find.

Akemi
toracat

toracat

2007-04-18 19:07

manager   ~0004832

I tested the x86_64 version of cifs.ko and it worked as well.

Akemi
toracat

toracat

2007-04-30 09:48

manager   ~0005038

Tested OK with the x86_64plus version.

Akemi
toracat

toracat

2007-05-07 10:02

manager   ~0005103

Tested with the new kernel-2.6.18-8.1.3.el5.x86_64. Loaded and worked fine.

Akemi
JohnnyHughes

JohnnyHughes

2007-05-12 08:25

administrator   ~0005159

New RH bug and this is being added to RHEL kernel. It is in kernels> 2.6.18-17.el5. More info here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=224359
toracat

toracat

2007-05-22 15:02

manager   ~0005211

Last edited: 2007-05-23 22:49

Tested with the new kernel-2.6.18-8.1.4.el5.i386. Loaded and worked fine.

Akemi

added - worked with 2.6.18-8.1.4.el5.centos.plus.x86_64

toracat

toracat

2007-06-02 12:34

manager   ~0005279

Last edited: 2007-06-02 12:37

Newly released CentOS 4.5 uses cifs 1.45 which contains the bug reported here. It was unfortunate that upstream did not patch it before the release.

Akemi

Note added: reported upstream.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242110

toracat

toracat

2007-06-03 00:41

manager   ~0005280

Last edited: 2007-06-03 06:43

RH is offering test kernels for RHEL4.5 with the patch at:

http://people.redhat.com/jlayton/

Tested with kernel-2.6.9-55.4.EL.jtltest.9.i686.rpm and confirmed that the bug has been fixed in this kerel.

Akemi

s/kerel/kernel/

toracat

toracat

2007-06-26 15:07

manager   ~0005479

The cifs.ko module for C5.0 provided by hughesjr tested OK with the latest kernels:

2.6.18-8.1.6.el5 (i686)
2.6.18-8.1.6.el5.centos.plus (x86_64)
toracat

toracat

2007-07-09 16:17

manager   ~0005542

http://people.redhat.com/jlayton/

now offers test kernels for both RHEL 4 and 5 that have cifs 1.48 backported. This fixes many other cifs bugs including the one reported here.

For the list of bugs fixed as of 1.48, see this ML post:

http://lists.centos.org/pipermail/centos/2007-July/083636.html

Akemi
toracat

toracat

2007-07-27 16:44

manager   ~0005749

Now it is official that RHEL4U6 will have cifs 1.48.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239339

(Note that 1.48 has already been committed to CVS for RHEL5.1)

Akemi
toracat

toracat

2007-11-02 22:36

manager   ~0006225

The Release Notes for RHEL 5.1 says:

"The CIFS client has been updated to version 1.48aRH"

So, it is real now!
Charlie Brady

Charlie Brady

2007-11-03 03:02

reporter   ~0006226

> Might be fixed in the kernel here:
> http://people.redhat.com/linville/kernels/rhel5/ [^]

The changelog suggests so:
...
* Mon Oct 22 2007 Don Zickus <dzickus@redhat.com> [2.6.18-54.el5]
...
- [cifs] fix memory corruption due to bad error handling (Jeff Layton ) [336501]
- [net] bnx2: Add PHY workaround for 5709 A1 (Andy Gospodarek ) [317331]
...
* Mon Aug 20 2007 Don Zickus <dzickus@redhat.com> [2.6.18-42.el5]
...
- [fs] CIFS: fix deadlock in cifs_get_inode_info_unix (Jeff Layton ) [249394]
...
* Wed Jun 13 2007 Don Zickus <dzickus@redhat.com> [2.6.18-25.el5]
- [s390] fix possible reboot hang on s390 (Jan Glauber ) [222181]
- [cifs] Update CIFS to version 1.48aRH (Jeff Layton ) [238597]
...
toracat

toracat

2007-11-13 02:34

manager   ~0006286

The 5.1 kernel 2.6.18-53 is out. Confirmed that it has cifs 1.48aRH.

The upcoming 4.6 is expected to include the same cifs.
toracat

toracat

2007-11-16 15:36

manager   ~0006333

The 4.6 kernel 2.6.9-67 is out. Confirmed that it has cifs 1.48aRH.

With both 5.1 and 4.6 kernels fixed, this bug report can be marked resolved (maybe after the official CentOS versions become available?).

Akemi
toracat

toracat

2007-11-27 02:34

manager   ~0006405

The CentOS 4.6 kernel 2.6.9-67 is now available in the QA tree. Confirmed that it has the patched cifs.ko.

$ cat /proc/fs/cifs/DebugData
Display Internal CIFS Data Structures for Debugging
---------------------------------------------------
CIFS Version 1.48a.RH

This bug report can finally be marked "Resolved" now. Johnny, would you please go ahead and do it?

Akemi
JohnnyHughes

JohnnyHughes

2007-11-27 12:54

administrator   ~0006412

also fixed for centos-4.6.

Both trees are currently in QA mode.

Issue History

Date Modified Username Field Change
2007-03-14 00:23 toracat New Issue
2007-03-14 00:23 toracat Status new => assigned
2007-03-14 01:26 GregSwallow Note Added: 0004564
2007-03-14 03:04 JohnnyHughes Note Added: 0004565
2007-03-15 17:41 toracat Note Added: 0004580
2007-03-15 17:52 toracat Note Added: 0004581
2007-03-20 21:44 Charlie Brady Note Added: 0004630
2007-04-12 16:43 toracat Note Added: 0004783
2007-04-14 10:00 toracat Note Added: 0004790
2007-04-17 18:12 JohnnyHughes Note Added: 0004823
2007-04-17 18:14 JohnnyHughes Note Edited: 0004823
2007-04-17 18:15 JohnnyHughes Status assigned => confirmed
2007-04-17 18:53 toracat Note Added: 0004824
2007-04-18 19:07 toracat Note Added: 0004832
2007-04-30 09:48 toracat Note Added: 0005038
2007-05-07 10:02 toracat Note Added: 0005103
2007-05-12 08:25 JohnnyHughes Note Added: 0005159
2007-05-22 15:02 toracat Note Added: 0005211
2007-05-23 22:49 toracat Note Edited: 0005211
2007-06-02 12:34 toracat Note Added: 0005279
2007-06-02 12:37 toracat Note Edited: 0005279
2007-06-03 00:41 toracat Note Added: 0005280
2007-06-03 06:43 toracat Note Edited: 0005280
2007-06-26 15:07 toracat Note Added: 0005479
2007-07-09 16:17 toracat Note Added: 0005542
2007-07-10 13:50 JohnnyHughes Relationship added related to 0002194
2007-07-26 19:54 JohnnyHughes Relationship added related to 0001062
2007-07-26 19:57 JohnnyHughes Relationship replaced has duplicate 0002194
2007-07-27 16:44 toracat Note Added: 0005749
2007-11-02 22:36 toracat Note Added: 0006225
2007-11-03 03:02 Charlie Brady Note Added: 0006226
2007-11-13 02:34 toracat Note Added: 0006286
2007-11-16 15:36 toracat Note Added: 0006333
2007-11-27 02:34 toracat Note Added: 0006405
2007-11-27 12:54 JohnnyHughes Status confirmed => resolved
2007-11-27 12:54 JohnnyHughes Fixed in Version => 5.1
2007-11-27 12:54 JohnnyHughes Resolution open => fixed
2007-11-27 12:54 JohnnyHughes Note Added: 0006412