View Issue Details

IDProjectCategoryView StatusLast Update
0017788CentOS-8qemu-kvmpublic2020-10-09 07:18
Reporteramather 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version8.2.2004 
Target VersionFixed in Version 
Summary0017788: nested virtualization: Win10 Guest with hypervisor features hits boot loop in 8.2, but not in 8.1
DescriptionWith the current qemu-kvm package in 8.2, I'm unable to boot a Win10 Pro VM with hypervisor enabled - Windows will boot loop and finally hit Automatic Repair. This works though if I downgrade the qemu-kvm package to the version shipped with 8.1.

Not working:
qemu-kvm-2.12.0-99 (CentOS 8.2 / AppStream)

Working:
qemu-kvm-2.12.0-88 (CentOS 8.1 / AppStream)

Steps To Reproduce- install CentOS 8.2
- create windows VM (in my case: UEFI, no secureboot, host-passthrough in libvirt config)
- install hypervisor features within windows
- reboot VM

To allow windows VM to boot, disable hypervisor feature, e.g.:
    <feature policy='disable' name='hypervisor'/>

This allows the VM to boot, but no nested virtualization is working.
Additional InformationI've tried to windbg the VM, but as I'm not skilled in this area the only thing I can report is that I hit a lot of Access Violation exceptions, multiple of which happened within OslArchHypervisorSetup.

I've also tried several different qemu configs (enable secureboot, try different CPU features, etc.) but to no avail. The only thing that worked was to downgrade the qemu-kvm package.

Also, I'm not the only one to experience this, as I got the clue from serverfault:
https://serverfault.com/questions/1036113/l0-kvm-and-win10-l1-nested-virtualization-not-working-windows-boot-loop

I have no access to RHEL, but it's possible the problem exists there as well.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-10-09 07:18 amather New Issue