View Issue Details

IDProjectCategoryView StatusLast Update
0017826CentOS-7phppublic2020-11-03 20:49
Reporternoloader 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0017826: CentOS 7 with SCL enabled only provides PHP 7.3.11
DescriptionHi Everyone,

My apologies if this is the wrong place to report this issue.

We have a CentOS 7 VM with Red Hat's SCL enabled. It runs our website and wiki at https://www.cryptopp.com. SCL is enabled so we can get an updated Apache, Python, PHP and friends.

Our current Mediawiki is 1.34. 1.34 is _not_ a Long Term Support (LTS) release. We want to migrate to Mediawiki 1.35. 1.35 is a LTS release.

We cannot migrate to Mediawiki 1.35 at the moment because CentOS 7 and SCL only provides PHP 7.3.11. Mediawiki 1.35 requires PHP 7.3.19.

Our request is, please bump PHP's version to 7.3.19 so we can install Mediawiki 1.35.

Also see https://www.mediawiki.org/wiki/Talk:MediaWiki_1.35. It asks Mediawiki to downgrade their PHP requirements.
TagsNo tags attached.
abrt_hash
URL

Activities

tigalch

tigalch

2020-11-01 07:39

manager   ~0037838

You would have to raise this issue with RH. If they upgrade SCL, the rebuilds will also get updated. You could also try one of the 3rd party repos (i.e. IUS) which replace stock PHP with the most current 7.3 release.
jorton

jorton

2020-11-02 09:17

reporter   ~0037839

We have rebased rh-php73 to 7.3.20 in RHSCL 3.6 Beta.

https://access.redhat.com/documentation/en-us/red_hat_software_collections/3-beta/html/3.6_release_notes/chap-rhscl
noloader

noloader

2020-11-02 09:52

reporter   ~0037840

Thanks tigalch and jorton. The PHP bump is going to be very helpful to folks.
tigalch

tigalch

2020-11-03 20:49

manager   ~0037843

PHP version has been updated

Issue History

Date Modified Username Field Change
2020-11-01 07:34 noloader New Issue
2020-11-01 07:39 tigalch Note Added: 0037838
2020-11-02 09:17 jorton Note Added: 0037839
2020-11-02 09:52 noloader Note Added: 0037840
2020-11-03 20:49 tigalch Status new => resolved
2020-11-03 20:49 tigalch Resolution open => fixed
2020-11-03 20:49 tigalch Note Added: 0037843