View Issue Details

IDProjectCategoryView StatusLast Update
0017864CentOS-7kernelpublic2020-11-18 08:07
Reporteryinzg 
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionwon't fix 
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0017864: The nvme driver or hotplug works abnormally when the hot plug is performed under multiple namespace using NVMe SSD
DescriptionThe nvme driver or hotplug works abnormally when the hot plug is performed under multiple namespace using NVMe SSD. The dmesg info is as belows,
[ 595.773490] pciehp 0000:16:01.0:pcie004: Slot(32-1): Link Down event queued; currently getting powered on
 [ 605.403407] INFO: task kworker/3:1:165 blocked for more than 120 seconds.
 [ 605.403413] Not tainted 4.10.0-28-generic #32~16.04.2-Ubuntu
 [ 605.403414] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
 [ 605.403416] kworker/3:1 D 0 165 2 0x00000000
 [ 605.403425] Workqueue: pciehp-32 pciehp_power_thread
 [ 605.403427] Call Trace:
 [ 605.403433] __schedule+0x232/0x700
 [ 605.403439] ? update_curr+0xf3/0x180
 [ 605.403441] schedule+0x36/0x80
 [ 605.403443] schedule_preempt_disabled+0xe/0x10
 [ 605.403445] __mutex_lock_slowpath+0x193/0x290
 [ 605.403447] mutex_lock+0x2f/0x40
 [ 605.403449] pciehp_power_thread+0x33/0xb0
 [ 605.403454] process_one_work+0x16b/0x4a0
 [ 605.403456] worker_thread+0x4b/0x500
 [ 605.403459] kthread+0x109/0x140
 [ 605.403461] ? process_one_work+0x4a0/0x4a0
 [ 605.403464] ? kthread_create_on_node+0x60/0x60
 [ 605.403467] ret_from_fork+0x2c/0x40
 [ 605.403483] INFO: task kworker/3:2:777 blocked for more than 120 seconds.
 [ 605.403485] Not tainted 4.10.0-28-generic #32~16.04.2-Ubuntu
 [ 605.403486] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
 [ 605.403487] kworker/3:2 D 0 777 2 0x00000000
 [ 605.403491] Workqueue: pciehp-32 pciehp_power_thread
Can you help confirm the reason for me to debug the problem ? Thanks!
Steps To ReproduceUse multi-ns SSD to format the SSD using the format NVMe Command and then hotplug it again and again. Then the SSD can not be recognized normally.
TagsNo tags attached.
abrt_hash
URL

Activities

TrevorH

TrevorH

2020-11-18 08:03

manager   ~0037919

Why are you reporting problems with an Ubuntu kernel on the CentOS bug tracker? This is not the correct place.

Issue History

Date Modified Username Field Change
2020-11-18 07:55 yinzg New Issue
2020-11-18 08:03 TrevorH Status new => closed
2020-11-18 08:03 TrevorH Resolution open => won't fix
2020-11-18 08:03 TrevorH Note Added: 0037919