View Issue Details

IDProjectCategoryView StatusLast Update
0017909CentOS-7crashpublic2021-03-26 03:54
Reporterkly_dream Assigned To 
Status newResolutionopen 
Product Version7.9.2009 
Summary0017909: Installation failed on Ryzen 5800x and ASUS x570 TUF GAMING X570-PLUS wifi
DescriptionI have tried Centos 7.7 and newest version, and met same issue.
TagsNo tags attached.


has duplicate 0017908 closed Installation failed on Ryzen 5800x and ASUS x570 TUF GAMING X570-PLUS wifi 




2020-12-05 12:50


108061922.jpg (166,967 bytes)   
108061922.jpg (166,967 bytes)   
1055642847.jpg (143,970 bytes)   
1055642847.jpg (143,970 bytes)   


2020-12-05 12:54

reporter   ~0038031

Can any one tell me the root cause of this issue: which cause this: New cpu or some onboard hardware?


2020-12-05 14:44

manager   ~0038042

my best guess is the new CPU. Have you tried with CentOS 8.2?


2020-12-05 15:01

manager   ~0038043

I've seen several reports of the new Ryzen 5xxxX chips failing on CentOS 7.9. You will need to report this on to get any potential fix and for 7, I'm not sure that's likely to happen. You can try though... or buy an older 3xxx Ryzen instead as they work.


2020-12-05 17:33

manager   ~0038044

As @tigalch suggested, you want to install CentOS 8.2, or soon-to-come 8.3.

If you need to stay with CentOS 7, give ELRepo's kernel-ml a try.


2021-03-25 18:58

reporter   ~0038332

I am having the same issue with the same processor, but with the Gigabyte B500 Aorus Pro AC. I had been running that mobo with a Ryzen 3600X with CentOS 7.x just fine with the F1 BIOS. I upgraded to the F12 BIOS and it still ran fine and I let it run for a day to be reasonably sure. I made sure I was patched up to kernel-3.10.0-1160.21.1.el7.x86_64 before swapping the CPUs and I crashed on the way up with the kernel panic within a second of selecting the kernel to load from the grub menu.

I also tried dumbing down the system by deselecting features in BIOS, which had no impact. This included turning off C State support, turbo modes and SVM.

I then restored my previous BIOS settings, swapped back to the 3600X and I am back in operation, though not with the CPU upgrade I was looking for.


2021-03-26 03:54

manager   ~0038333

psmode: if you must stick with CentOS 7, your best bet is using ElRepo's kernel-ml. RHEL 7 ( and by matter of consequence CentOS 7 ) is in its last stage of maintenance which means that it gets only fixes RH feels that are "important" ( which usually translates in high-risk security issues ) and therefore no new features are backported. The chances of seeing an addition to the kernel to properly support new CPUs are extremely slim.

Issue History

Date Modified Username Field Change
2020-12-05 12:50 kly_dream New Issue
2020-12-05 12:50 kly_dream File Added: 108061922.jpg
2020-12-05 12:50 kly_dream File Added: 1055642847.jpg
2020-12-05 12:54 kly_dream Note Added: 0038031
2020-12-05 14:44 tigalch Note Added: 0038042
2020-12-05 15:01 TrevorH Note Added: 0038043
2020-12-05 17:33 toracat Note Added: 0038044
2020-12-05 18:11 toracat Relationship added has duplicate 0017908
2021-03-25 18:58 psmode Note Added: 0038332
2021-03-26 03:54 ManuelWolfshant Note Added: 0038333