View Issue Details

IDProjectCategoryView StatusLast Update
0017961CentOS-8anacondapublic2020-12-30 08:20
Reporterladar Assigned To 
Status newResolutionopen 
Product Version8.3.2011 
Summary0017961: 8.3.2011 install ISOs can't use network repos with kickstart files
DescriptionBased on my testing the CentOS-8.3.2011-x86_64-dvd1.iso and CentOS-8.3.2011-x86_64-boot.iso don't appear to work using a kickstart file, if you specify a network repo. I tried a variety of repo urls including BaseOS/x86_64/os/ (which should work), along with BaseOS/x86_64/os/media.repo and BaseOS/x86_64/kickstart/. I tried pointing the kickstart file at the 8.2.2004 repos on the vault server. I tried HTTP and HTTPS. Nothing seemed to work. Note, I asked for the text installer in my kickstart file. I also tried changing the name of the repo, in case that was the issue.

If I boot from the 8.2.2004 install ISOs, everything works just fine, whether it's pointed at the 8.2.2004 repo, or the 8.3.2011.

I have previously installed 8.3.2011 over the network, manually, using the graphical installer, so I know that works just fine. So this might only be an issue with the text installer, and/or if a kickstart file is in use.

I'm a attaching a kickstart file for testing. Note this kickstart file works just fine using the DVD installer, with the network repos disabled.
Steps To ReproduceBoot and try installing with the provided kickstart file.
TagsNo tags attached.




2020-12-18 16:27


centos8.ks (646 bytes)   

lang en_US.UTF-8
keyboard us
timezone US/Pacific


firstboot --disabled
selinux --enforcing
firewall --enabled --service=ssh

network --device eth0 --bootproto dhcp --noipv6 --hostname=centos8.localdomain

clearpart --all --initlabel
bootloader --location=mbr --append="net.ifnames=0 biosdevname=0 no_timer_check"
autopart --nohome

rootpw vagrant
authconfig --enableshadow --passalgo=sha512

reboot --eject

repo --name=BaseOS
url --url=

%packages --instLangs=en_US.utf8
centos8.ks (646 bytes)   


2020-12-18 21:15

reporter   ~0038110

I was looking over some of my configs, and realized I've done successful network installs using the 8.3.2011 ISOs and the graphical installer. So this issue is probably specific to the anaconda text installer.


2020-12-19 17:47

reporter   ~0038122

This URL works for me: url --mirrorlist="$infra"

The whole kickstart file is available here:

Note that, as I explain in issue #0017940, if I use it in the graphical installer only a few of the usual software options are available.


2020-12-29 21:30

reporter   ~0038144

nmusatti were you able to get it working if you specify the repo URL instead of the mirrorlist? And more importantly, what happens if that repo URL uses HTTPS?

As a rule, I try I avoid using HTTP, and the mirrorlist server doesn't support requests over HTTPS or (last I checked), returning HTTPS URLs.

Also, when i did my testing, I checked the mirrorlist URL and tried providing the URLs directly, so I find it strange that they would work if provided via the mirrorlist, but don't work when dictated directly.


2020-12-30 08:20

reporter   ~0038146

I never tried anything different from a mirrorlist URL, nor https variations, sorry.

Issue History

Date Modified Username Field Change
2020-12-18 16:27 ladar New Issue
2020-12-18 16:27 ladar File Added: centos8.ks
2020-12-18 21:15 ladar Note Added: 0038110
2020-12-19 17:47 nmusatti Note Added: 0038122
2020-12-29 21:30 ladar Note Added: 0038144
2020-12-30 08:20 nmusatti Note Added: 0038146